bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Causes crash in www.slashdot.org (dump included)

VERIFIED DUPLICATE of bug 52397

Status

()

Core
Networking
VERIFIED DUPLICATE of bug 52397
18 years ago
18 years ago

People

(Reporter: Joseph Wang, Assigned: neeti)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.0-0.10mdk i586)
BuildID:    20001221

Seg fault here is the dump

#0  0x41ea51c3 in nsHTTPServerListener::OnDataAvailable (this=0x8698cb8,
channel=0x86b6fdc, context=0x88cedf8, i_pStream=0x8791e80, i_SourceOffset=0,
i_Length=2746) at nsHTTPResponseListener.cpp:451
#1  0x41e3a44d in nsOnDataAvailableEvent::HandleEvent (this=0x87b36c0) at
nsAsyncStreamListener.cpp:407
#2  0x41e39614 in nsStreamListenerEvent::HandlePLEvent (aEvent=0x87b36cc) at
nsAsyncStreamListener.cpp:92
#3  0x401293ec in PL_HandleEvent (self=0x87b36cc) at plevent.c:576
#4  0x401291e9 in PL_ProcessPendingEvents (self=0x8865848) at plevent.c:509
#5  0x4012b250 in nsEventQueueImpl::ProcessPendingEvents (this=0x8887c10) at
nsEventQueue.cpp:356
#6  0x40aaed34 in event_processor_callback (data=0x8887c10, source=29,
condition=GDK_INPUT_READ) at nsAppShell.cpp:158
#7  0x40aae903 in our_gdk_io_invoke (source=0x8857a10, condition=G_IO_IN,
data=0x8886058) at nsAppShell.cpp:58
#8  0x4095ccd9 in ?? () from /usr/lib/libglib-1.2.so.0
#9  0x4095edd4 in ?? () from /usr/lib/libglib-1.2.so.0
#10 0x4067f665 in ?? () from
/home/joe/mozilla/dist/bin/components/libnsappshell.so
#11 0x4068a55f in ?? () from
/home/joe/mozilla/dist/bin/components/libnsappshell.so
#12 0x4067b9fb in ?? () from
/home/joe/mozilla/dist/bin/components/libnsappshell.so
#13 0x40568218 in ?? () from /home/joe/mozilla/dist/bin/libjsdom.so
#14 0x405623a4 in ?? () from /home/joe/mozilla/dist/bin/libjsdom.so
#15 0x40696fda in ?? () from
/home/joe/mozilla/dist/bin/components/libnsappshell.so
#16 0x40695da1 in ?? () from
/home/joe/mozilla/dist/bin/components/libnsappshell.so
#17 0x4068c9ec in ?? () from
/home/joe/mozilla/dist/bin/components/libnsappshell.so
#18 0x42468231 in ?? () from /home/joe/mozilla/dist/bin/components/libwallet.so
#19 0x4201755d in ?? () from /home/joe/mozilla/dist/bin/components/libpsmglue.so
#20 0x42016630 in ?? () from /home/joe/mozilla/dist/bin/components/libpsmglue.so
#21 0x41fd01b3 in ?? () from
/home/joe/mozilla/dist/bin/components/liburiloader.so
#22 0x41fcfc1b in ?? () from
/home/joe/mozilla/dist/bin/components/liburiloader.so
#23 0x4014b308 in XPTC_InvokeByIndex (that=0x8689a28, methodIndex=3,
paramCount=4, params=0x86f3010) at xptcinvoke_unixish_x86.cpp:134
#24 0x40130e6b in EventHandler (self=0x86f2fe8) at nsProxyEvent.cpp:510
#25 0x40130c5a in nsProxyObject::Post (this=0x88cf110, methodIndex=3,
methodInfo=0x823d918, params=0xbffff244, interfaceInfo=0x80c45e0) at
nsProxyEvent.cpp:453
#26 0x40133435 in nsProxyEventObject::CallMethod (this=0x88cf0e8, methodIndex=3,
info=0x823d918, params=0xbffff244) at nsProxyEventObject.cpp:429
#27 0x4014b6be in PrepareAndDispatch (self=0x88cf0e8, methodIndex=3,
args=0xbffff304) at xptcstubs_unixish_x86.cpp:80
#28 0x4014b759 in nsXPTCStubBase::Stub3 (this=0x88cf0e8) at
../../../../../../dist/include/xptcstubsdef.inc:5
#29 0x41e99f44 in nsHTTPChannel::ReportProgress (this=0x88cedf8, aProgress=5124,
aProgressMax=4294967295) at nsHTTPChannel.cpp:1639
#30 0x41ea5ba5 in nsHTTPServerListener::OnDataAvailable (this=0x8698cb8,
channel=0x86b6fdc, context=0x88cedf8, i_pStream=0x8791e80, i_SourceOffset=2896,
i_Length=5124) at nsHTTPResponseListener.cpp:563
#31 0x41e3a44d in nsOnDataAvailableEvent::HandleEvent (this=0x8838ed8) at
nsAsyncStreamListener.cpp:407
#32 0x41e39614 in nsStreamListenerEvent::HandlePLEvent (aEvent=0x8838ee4) at
nsAsyncStreamListener.cpp:92
#33 0x401293ec in PL_HandleEvent (self=0x8838ee4) at plevent.c:576
#34 0x401291e9 in PL_ProcessPendingEvents (self=0x80c76e8) at plevent.c:509
#35 0x4012b250 in nsEventQueueImpl::ProcessPendingEvents (this=0x80c76c0) at
nsEventQueue.cpp:356
#36 0x40aaed34 in event_processor_callback (data=0x80c76c0, source=5,
condition=GDK_INPUT_READ) at nsAppShell.cpp:158
#37 0x40aae903 in our_gdk_io_invoke (source=0x825ef68, condition=G_IO_IN,
data=0x8288e88) at nsAppShell.cpp:58
#38 0x4095ccd9 in ?? () from /usr/lib/libglib-1.2.so.0

The relevant line is
  if (NS_SUCCEEDED(rv1)) 
            mResponseDataListener->OnDataAvailable(mChannel, 
                    mChannel->mResponseContext, is, 0, mHeaderBuffer.Length()) ;

And the problem is

(gdb) print mResponseDataListener
$2 = {mRawPtr = 0x0}


Reproducible: Sometimes
Steps to Reproduce:
1. Look at http://www.slashdot.org/	
2. 
3.

Actual Results:  seg fault		

Expected Results:  No seg fault

Comment 1

18 years ago
Looks like a dup of bug 52397

Comment 2

18 years ago
You're right! Same stack trace.
Marking dupe of bug 52397: "RTM Crash #9 [@
nsHTTPServerListener::OnDataAvailable]"

*** This bug has been marked as a duplicate of 52397 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 3

18 years ago
verified dup
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.