Restarting Firefox is impossible after Updater crashes

RESOLVED WORKSFORME

Status

()

Firefox
General
--
critical
RESOLVED WORKSFORME
7 years ago
6 years ago

People

(Reporter: Mark Slater, Unassigned)

Tracking

({crash})

Trunk
x86
Mac OS X
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b12pre) Gecko/20110221 Firefox/4.0b12pre
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b12pre) Gecko/20110221 Firefox/4.0b12pre

Starting Firefox after the updater crashed in a previous start-up stops Firefox from working

Reproducible: Always

Steps to Reproduce:
1. Have updater crash on start-up
2. Try restarting Firefox
3.
Actual Results:  
Firefox crashes again, refusing to start.

Expected Results:  
Firefox should just start as expected, without crashing.

From OS X's crash report:

Process:         firefox-bin [331]
Path:            /Applications/Minefield.app/Contents/MacOS/firefox-bin
Identifier:      org.mozilla.minefield
Version:         ??? (???)
Code Type:       X86-64 (Native)
Parent Process:  launchd [219]

Date/Time:       2011-02-22 07:27:15.662 -0500
OS Version:      Mac OS X 10.6.6 (10J567)
Report Version:  6

Interval Since Last Report:          15964 sec
Crashes Since Last Report:           5
Per-App Crashes Since Last Report:   4
Anonymous UUID:                      818CC718-F504-40EA-B3FC-4DBEF4083C4B

Exception Type:  EXC_BREAKPOINT (SIGTRAP)
Exception Codes: 0x0000000000000002, 0x0000000000000000
Crashed Thread:  0

Dyld Error Message:
  Library not loaded: @executable_path/XUL
  Referenced from: /Applications/Minefield.app/Contents/MacOS/firefox-bin
  Reason: no suitable image found.  Did find:
	/Applications/Minefield.app/Contents/MacOS/XUL: truncated fat file.  file length=69474024, but needed slice goes to 94103768
	/Applications/Minefield.app/Contents/MacOS/XUL: truncated fat file.  file length=69474024, but needed slice goes to 94103768

Updated

7 years ago
Version: unspecified → Trunk

Updated

7 years ago
Keywords: crash
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.