bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Attachments are hard to discover

RESOLVED DUPLICATE of bug 282068

Status

Thunderbird
Message Reader UI
RESOLVED DUPLICATE of bug 282068
8 years ago
7 years ago

People

(Reporter: andreasn, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
One thing we discovered during the Thunderbird UI testing in London [1] was
that finding attachments in e-mails were quite hard.
Because of this, most of the participants had a hard time finding attachments in e-mails and opening them.
I was totally surprised by this, so it was great to discover this.

1. http://design.canonical.com/2011/02/thunderbird-in-the-usability-lab/

Comment 1

8 years ago
The user's expectation to find the attachments in the header area may come from many other e-mail clients and web-mail systems doing so. Thus, Thunderbird is a bit unique by presenting the attachments at the bottom of the message, though technically that's where they are located.

Moving the attachment-pane area back to the message headers (as they were in the Mozilla Suite and still are in SeaMonkey) may be difficult to accomplish now that a lot of UI elements (action buttons and menus) have moved into it already, thus it's getting crowded there.

I'm wondering if the learning curve to find the attachments the first time is steep enough to warrant any action. Other actions (find in message, attachment reminder, etc.) require the user's attention at the bottom of the message pane as well. Once they are found, the user knows where to expect those items.

For composition, the initial absence of the attachment pane before dragging a file over it is frequently confusing, and indeed it's also unclear which file is edited and what its consequences are for the attachment when it is opened and modified (also see bug 378046 and others in this ambiguity).

Comment 2

8 years ago
(In reply to comment #1)
> The user's expectation to find the attachments in the header area may come from
> many other e-mail clients and web-mail systems doing so.

Gmail puts attachments at the bottom like Thunderbird does, though Gmail uses up considerably more space to do so (not that we'd necessarily want to emulate that part).
(Reporter)

Comment 3

8 years ago
As the key thing is discoverability of the attachments in the message, I don't think putting them at the top is the only solution.
Bug 282068 will have a label saying "Attachments". Lets see if that helps. Might need to do something with the colors to make it appear less as chrome too.

Updated

7 years ago
Duplicate of this bug: 537791

Updated

7 years ago
Blocks: 579473

Comment 5

7 years ago
Should this be marked fixed? I suppose it could be reopened later if people still have a hard time discovering the attachments pane, but I think it's ok now.
(Reporter)

Comment 6

7 years ago
Yes, lets close it!
We should do some testing on the feature again in the future.

Not sure if this should be marked as a duplicate of 282068, but I guess it is. Feel free to change if I'm wrong. :)
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 282068
You need to log in before you can comment on or make changes to this bug.