nagios and inventory disagree with DNS on hostnames: moz2-win32-slaveNN

RESOLVED FIXED

Status

RESOLVED FIXED
8 years ago
5 years ago

People

(Reporter: dustin, Assigned: arich)

Tracking

Details

All of the win32-slaveNN hosts appear in Nagios, inventory, and reverse DNS as moz2-win32-slaveNN.  Rather than do a bulk hostname change, I'd rather see nagios and inventory updated to match forward DNS.

staging-opsi:~# host win32-slave03
win32-slave03.build.mozilla.org CNAME   win32-slave3.build.sjc1.mozilla.com
win32-slave3.build.sjc1.mozilla.com     A       10.2.71.119

staging-opsi:~# host 10.2.71.119
Name: moz2-win32-slave03.build.mozilla.org
Address: 10.2.71.119

staging-opsi:~# host moz2-win32-slave03
moz2-win32-slave03.build.mozilla.org    CNAME   win32-slave03.build.mozilla.org
win32-slave03.build.mozilla.org CNAME   win32-slave3.build.sjc1.mozilla.com
win32-slave3.build.sjc1.mozilla.com     A       10.2.71.119
(Assignee)

Updated

8 years ago
Assignee: server-ops-releng → arich
This was fixed by zandr a few days ago in a followup.

I do notice this:

win32-slave03.build.mozilla.org CNAME   win32-slave3.build.sjc1.mozilla.com

which should probably be fixed (adding zero-padding in the build.sjc1.mozilla.com zone).  I'll open a new bug.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 624951
er, bug 642951 - sorry
Duplicate of bug: 642951
(Assignee)

Comment 3

8 years ago
According to rtucker, the nagios generation script requires that the PTR matches the A, so there needs to be a DNS change for the PTR records coordinated with nagios config changes in hosts.h, services,h and hostgroups.cfg.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Assignee)

Updated

8 years ago
Depends on: 646126
(Assignee)

Comment 4

8 years ago
This got cleaned up with 645039.
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → FIXED
Component: Server Operations: RelEng → RelOps
Product: mozilla.org → Infrastructure & Operations
You need to log in before you can comment on or make changes to this bug.