bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Offline Application Caching and Cache Manifest should log errors when bailing

RESOLVED DUPLICATE of bug 807501

Status

()

Core
Networking: Cache
RESOLVED DUPLICATE of bug 807501
8 years ago
6 years ago

People

(Reporter: ozten, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
Fx4b11 Mozilla/5.0 (X11; Linux i686; rv:2.0b11) Gecko/20100101 Firefox/4.0b11

As a web developer, I find this feature hard to test (or buggy).
Assumptions:
* Work Offline would be a fine way to test
* Pasting and Go, refresh, and hard refresh while offline should all show offline content

1) Load a webapp with a cache.manifest (Example [1] or [2])
Note: Prompted for offline access, so far so good :)

Load this into 3 tabs (for steps 3, 4, and 5 below).

2) File > Work Offline
3) Hit Refresh button 

Actual - No change
Expected - Offline behaviors

4) Paste url and hit enter into location bar

Actual - No change
Expected - Offline behaviors

5) Hard refresh

Actual - No change
Expected - Offline behaviors

6) File > Uncheck Work Offline
7) Disable networking (for operating system)

8) about:cache - 0 entries in offline cache

Repeat 3, 4, 5, 8
Step 3 - Server Not Found
4 - Offline content shown
5 - Server Not Found

Once steps 3 or 5 have happened, a currently opened tab to test step 4 is also reset to "Server not found".

[1] http://www.html5laboratory.com/s/offline-application-cache.html
[2] http://getting.shitdone.org/
Austin, for the link [1] I am unable to reproduce any problem.  For the letter it seems that -something- doesn't work.  I'll check that out, please don't modify the test case if you can!

To make it clear, what all exactly means for you "Offline behaviors" ?

To be honest, it is hard to debug problems with offline caching.  We are not doing much error reporting and I find it my self not very convenient for web developers having more complex offline web apps to figure out what's wrong.  I agree there have to be done something about it.
(Reporter)

Comment 2

8 years ago
(In reply to comment #1)
Offline behaviors - Basic - the page should load. Loading via address bar or refreshing the page should not show the "Server not found" error page.
(Reporter)

Comment 3

8 years ago
I've determined what is going on.

In my manifest I had resources that were directories and not files.

Once I trimmed down my manifest to only resources (html, css, js, etc), caching is working better.

New Expected Behavior:
The JS Console should log an error when the code that caches resources from the manifest encounters and error and bails.

This logging should happen for any conditions that cause caching to "give up".
Summary: Offline Application Caching and Cache Manifest difficult to test or buggy → Offline Application Caching and Cache Manifest should log errors when bailing
(In reply to Austin King [:ozten] from comment #3)
> New Expected Behavior:
> The JS Console should log an error when the code that caches resources from
> the manifest encounters and error and bails.
> 
> This logging should happen for any conditions that cause caching to "give
> up".

bug 807501
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 807501
You need to log in before you can comment on or make changes to this bug.