Remove `Paste' from History window

VERIFIED FIXED

Status

P3
normal
VERIFIED FIXED
18 years ago
14 days ago

People

(Reporter: bugzilla, Assigned: bugzilla)

Tracking

Trunk
x86
Windows ME

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

18 years ago
The `Paste' item in the Edit menu should be removed from the global history 
window.  History is read-only, and you shouldn't be allowed to paste into it 
(nor are you currently allowed to, anyways).

Comment 1

18 years ago
Created attachment 21494 [details] [diff] [review]
proposed fix - remove menuitem and command

Updated

18 years ago
Status: NEW → ASSIGNED
Whiteboard: fix in hand
Target Milestone: --- → mozilla0.8

Comment 2

18 years ago
On some platforms (Mac, for example), the "Paste" menuitem should be disabled 
instead of removed.

Comment 3

18 years ago
We've had this argument before, iirc macos likes "Can't Paste"
Keywords: patch, review

Comment 4

18 years ago
we'll fix that elsewhere in a seperate, mac-specific bug.

Comment 5

18 years ago
Timeless: it should be disabled. Menu items shold not change their names to 
indicate they're unusabe.

Comment 6

18 years ago
This one was thrashed to death over in bug 53800 on Undo in bookmarks. I think 
Matt (@netscape.com) may have a good solution in a patch on that bug. The 
solutions should probably be mde conistent.

Updated

18 years ago
Keywords: patch, review
Priority: -- → P3
Target Milestone: mozilla0.8 → Future

Comment 7

18 years ago
ok, I left it out for now. I'm leaving this open, but futuring it so we fix it
right eventually

removing patch/review keywords since we need a new patch
(Assignee)

Updated

18 years ago
Whiteboard: fix in hand

Comment 8

18 years ago
fixed with patch for bug 64218 !?

Comment 9

18 years ago
sorry, maybe my above comments weren't clear: I removed paste with that checkin
(it was already in my tree) - but I'm leaving this bug open for a future fix.
(patches welcome)

Updated

18 years ago
Component: History: Session → History: Global

Comment 10

17 years ago
reassigning history bugs to new owner - send this bug back to me if it looks
like something I should fix (such as embedding-related architecture issues),
rather than the actual history owner...
Assignee: alecf → blakeross
Status: ASSIGNED → NEW
Target Milestone: Future → ---
(Assignee)

Comment 11

17 years ago
closing this.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
mass-verifying claudius' Fixed bugs which haven't changed since 2001.12.31.

if you think this particular bug is not fixed, please make sure of the following
before reopening:

a. retest with a *recent* trunk build.
b. query bugzilla to see if there's an existing, open bug (new, reopened,
assigned) that covers your issue.
c. if this does need to be reopened, make sure there are specific steps to
reproduce (unless already provided and up-to-date).

thanks!

[set your search string in mail to "AmbassadorKoshNaranek" to filter out these
messages.]
Status: RESOLVED → VERIFIED

Updated

14 days ago
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.