Tryserver emails should point to ftp, not stage

RESOLVED FIXED

Status

Release Engineering
General
RESOLVED FIXED
7 years ago
4 years ago

People

(Reporter: Benjamin Smedberg, Assigned: lsblakk)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

7 years ago
I just got this email from a tryserver run:

Your Try Server build (cfcd1af4189b) failed to complete on builder tryserver-linux.

The full log for this build run is available at http://stage.mozilla.org/pub/mozilla.org/firefox/tryserver-builds/bsmedberg@mozilla.com-cfcd1af4189b/tryserver-linux/tryserver-linux-build7196.txt.gz.

The link to stage.mozilla.org is unfortunate, because stage doesn't serve the logs in a way that can be viewed in-browser. If I s/stage/ftp/, I can view the log directly.
(Assignee)

Comment 1

7 years ago
Created attachment 515681 [details] [diff] [review]
Replace 'stage' with 'ftp' in try_mailer.py
Attachment #515681 - Flags: review?(catlee)
(Assignee)

Updated

7 years ago
Attachment #515681 - Flags: review?(catlee) → review?(aki)
(Assignee)

Comment 2

7 years ago
Created attachment 515688 [details] [diff] [review]
Replace '://stage' with '://ftp' in try_mailer.py
Attachment #515681 - Attachment is obsolete: true
Attachment #515681 - Flags: review?(aki)
Attachment #515688 - Flags: review?(aki)

Comment 3

7 years ago
Comment on attachment 515688 [details] [diff] [review]
Replace '://stage' with '://ftp' in try_mailer.py

This isn't perfect, but it works for now.
Attachment #515688 - Flags: review?(aki) → review+
(Assignee)

Comment 4

7 years ago
Comment on attachment 515688 [details] [diff] [review]
Replace '://stage' with '://ftp' in try_mailer.py

landed on default: http://hg.mozilla.org/build/buildbotcustom/rev/9b6447a12c3d
Attachment #515688 - Flags: checked-in+
(Assignee)

Updated

7 years ago
Flags: needs-reconfig?
(Assignee)

Comment 5

7 years ago
This has been merged into production. Please verify that you get ftp in your email links now and this bug can be closed.
Flags: needs-reconfig?
(Assignee)

Comment 6

7 years ago
checked in #developers to verify this is working as expected.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.