Crash on startup in nsGtkMain.cpp

VERIFIED WORKSFORME

Status

Core Graveyard
Embedding: GTK Widget
--
critical
VERIFIED WORKSFORME
17 years ago
6 years ago

People

(Reporter: brade, Assigned: Stuart Parmenter)

Tracking

({crash})

Trunk
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
For the last two weeks I can't get mozilla to run. It crashes on startup with

CanUnload_enumerate: skipping native
###!!! ASSERTION: NS_InitXPCOM failed: 'NS_SUCCEEDED(rv)', file nsGtkMain.cpp, 
line 171
###!!! Break: at file nsGtkMain.cpp, line 171

I built mozilla on SuSE Linux 7.0, glibc-2.1.3, XFree 4.02, kernel 2.2.18 with 
gcc-2.95.2. I have no .mozconfig and did a simple make -f client.mk.

Hope this helps,
  Michael

PS: I hope I chose the right component now...

Comment 1

17 years ago
I just built on a mandrake system today and it works fine. Did you check out
while the tree was green?

Comment 2

17 years ago
Marking WORKSFORME Due to lack of response. Reopen if this is still a problem in
the latest nightlies.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 3

17 years ago
Reopening heres a message from the reporter:

Anyway, here's the text I sent to doronr:

> you might want to try a new profile ./mozilla -profilemanager and see if
> the crash still exists with a new profile.

Hmm, changes just the output a little  [;-)] So I deleted everything that had to
do with mozilla completely, recompiled and now get still the following error:

CanUnload_enumerate: skipping native

###!!! ASSERTION: NS_InitXPCOM failed: 'NS_SUCCEEDED(rv)', file
nsAppRunner.cpp, line 1272
###!!! Break: at file nsAppRunner.cpp, line 1272
###!!! ASSERTION: Setting main thread twice?: 'Error', file nsThread.cpp,
line 379
###!!! Break: at file nsThread.cpp, line 379
###!!! ASSERTION: Setting main thread twice?: 'Error', file nsThread.cpp,

line 379
###!!! Break: at file nsThread.cpp, line 379
###!!! ASSERTION: Setting main thread twice?: 'Error', file nsThread.cpp,

line 379
###!!! Break: at file nsThread.cpp, line 379
###!!! ASSERTION: You can't dereference a NULL nsCOMPtr with operator->().:
'mRawPtr != 0', file ../../dist/include/nsCOMPtr.h, line 648
###!!! Break: at file ../../dist/include/nsCOMPtr.h, line 648
/mnt/Downloads/mozilla/dist/bin/run-mozilla.sh: line 72:  2848

Speicherzugriffsfehler  $prog ${1+"$@"}

BTW: "Speicherzugriffsfehler" means "segmentation fault".

I still got this two days ago, so I'm just recompiling. I will send you my
result this afternoon.

Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 4

17 years ago
More From Reporter:

Still the same. However, the crash is different if I type ./run-mozilla.sh
instead of ./mozilla:

Michael@Einstein:/mnt/Downloads/mozilla/dist/bin > ./run-mozilla.sh
MOZILLA_FIVE_HOME=.

LD_LIBRARY_PATH=.:/opt/qt-copy/lib:/opt/qt-copy/lib:/opt/qt-copy/lib:/opt/qt-copy/lib:/home/Michael/.kde/lib:/opt/kde-2/lib

LIBRARY_PATH=.:./components:/opt/qt-copy/lib:/opt/qt-copy/lib:/opt/qt-copy/lib:/opt/qt-copy/lib:/home/Michael/.kde/lib:/opt/kde-2/lib
       SHLIB_PATH=.
          LIBPATH=.
       ADDON_PATH=.
      MOZ_PROGRAM=./viewer
      MOZ_TOOLKIT=
        moz_debug=0
     moz_debugger=
CanUnload_enumerate: skipping native
###!!! ASSERTION: NS_InitXPCOM failed: 'NS_SUCCEEDED(rv)', file
nsGtkMain.cpp, line 171
###!!! Break: at file nsGtkMain.cpp, line 171

Now the other crash:

Michael@Einstein:/mnt/Downloads/mozilla/dist/bin > ./mozilla
./run-mozilla.sh ./mozilla-bin
MOZILLA_FIVE_HOME=/mnt/Downloads/mozilla/dist/bin

LD_LIBRARY_PATH=/mnt/Downloads/mozilla/dist/bin:/opt/qt-copy/lib:/opt/qt-copy/lib:/opt/qt-copy/lib:/opt/qt-copy/lib:/home/Michael/.kde/lib:/opt/kde-2/lib

LIBRARY_PATH=/mnt/Downloads/mozilla/dist/bin:/mnt/Downloads/mozilla/dist/bin/components:/opt/qt-copy/lib:/opt/qt-copy/lib:/opt/qt-copy/lib:/opt/qt-copy/lib:/home/Michael/.kde/lib:/opt/kde-2/lib
       SHLIB_PATH=/mnt/Downloads/mozilla/dist/bin
          LIBPATH=/mnt/Downloads/mozilla/dist/bin
       ADDON_PATH=/mnt/Downloads/mozilla/dist/bin
      MOZ_PROGRAM=./mozilla-bin
      MOZ_TOOLKIT=
        moz_debug=0
     moz_debugger=
CanUnload_enumerate: skipping native
###!!! ASSERTION: NS_InitXPCOM failed: 'NS_SUCCEEDED(rv)', file
nsAppRunner.cpp, line 1272
###!!! Break: at file nsAppRunner.cpp, line 1272
###!!! ASSERTION: Setting main thread twice?: 'Error', file nsThread.cpp,
line 379
###!!! Break: at file nsThread.cpp, line 379
###!!! ASSERTION: Setting main thread twice?: 'Error', file nsThread.cpp,
line 379
###!!! Break: at file nsThread.cpp, line 379
###!!! ASSERTION: Setting main thread twice?: 'Error', file nsThread.cpp,
line 379
###!!! Break: at file nsThread.cpp, line 379
###!!! ASSERTION: You can't dereference a NULL nsCOMPtr with operator->().:
'mRawPtr != 0', file ../../dist/include/nsCOMPtr.h, line 648
###!!! Break: at file ../../dist/include/nsCOMPtr.h, line 648
/mnt/Downloads/mozilla/dist/bin/run-mozilla.sh: line 72: 24437
Speicherzugriffsfehler  $prog ${1+"$@"}

BTW: the second crash is exactly the same that I get if I try to embed
mozilla in Konqueror with KMOZILLA.

Hope this helps.



Marking NEW as per comments.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: crash

Comment 5

17 years ago
I get the same exact problem.  RH 7.0 - 2.4.1 kernel

me@seanlangford.com
(Reporter)

Comment 6

17 years ago
Today I tried again: now it works for me! :-) So if this works
for Sean Langford (last additional comment) as well, you may close this
bug.

Thanks,
  Michael
resolving wfm per reporter's and my experience.
Status: NEW → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → WORKSFORME
email from Michael Brade:

"Btw, I know now why this crash happens: at the first startup time you need to 
have write permission to the mozilla dir - if you don't have it there will be 
exactly this crash! So I'd be very happy if you could make mozilla not crash 
but spit out some useful debug message in such a case."

asa, doron or pavlov --isn't there already a bug filed for this issue he
mentions...?

Comment 9

17 years ago
bug 41057 maybe?

Comment 10

17 years ago
okay, marking verified
Status: RESOLVED → VERIFIED
Component: Embedding: GTK Widget → Embedding: GTK Widget
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.