If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Only installed extensions should be used to calculate recommendations

RESOLVED FIXED in 5.12.11

Status

addons.mozilla.org Graveyard
Discovery Pane
--
major
RESOLVED FIXED
7 years ago
2 years ago

People

(Reporter: krupa, Assigned: cvan)

Tracking

unspecified
5.12.11

Details

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
steps to reproduce:
1. Start a new Firefox profile
2. Tools->Add-ons

expected behavior:
No recommendations when there are no installed add-ons

actual behavior:
Recommendations are shown when there no installed extensions
Whiteboard: [pickme]
(Assignee)

Comment 1

7 years ago
It looks like a new profile does install "add-ons." In a new profile, this is the URL that was loaded from my Add-ons Manager:

https://addons.allizom.org/en-US/firefox/discovery/pane/4.0b11/Darwin#{%22testpilot@labs.mozilla.com%22:{%22name%22:%22Feedback%22,%22version%22:%221.0.4%22,%22type%22:%22extension%22,%22userDisabled%22:false,%22isCompatible%22:true,%22isBlocklisted%22:false},%22{972ce4c6-7e08-4474-a285-3208198ce6fd}%22:{%22name%22:%22Default%22,%22version%22:%224.0b11%22,%22type%22:%22theme%22,%22userDisabled%22:false,%22isCompatible%22:true,%22isBlocklisted%22:false},%22{7948e846-73e1-474d-93e0-27c87e5ea838}%22:{%22name%22:%22DivX%20Web%20Player%22,%22version%22:%221.4%22,%22type%22:%22plugin%22,%22userDisabled%22:false,%22isCompatible%22:true,%22isBlocklisted%22:false},%22{5dbdcda8-455e-0845-85ce-44b947d72d7a}%22:{%22name%22:%22iPhotoPhotocast%22,%22version%22:%227.0%22,%22type%22:%22plugin%22,%22userDisabled%22:false,%22isCompatible%22:true,%22isBlocklisted%22:false},%22{e0aab536-eec5-c44e-ae0e-8df83cbd2b9b}%22:{%22name%22:%22SharePoint%20Browser%20Plug-in%22,%22version%22:%2214.0.0%22,%22type%22:%22plugin%22,%22userDisabled%22:false,%22isCompatible%22:true,%22isBlocklisted%22:false},%22{5106a403-3957-7d4f-887d-960c3be8bbff}%22:{%22name%22:%22Shockwave%20Flash%22,%22version%22:%2210.1.102.64%22,%22type%22:%22plugin%22,%22userDisabled%22:false,%22isCompatible%22:true,%22isBlocklisted%22:false},%22{19640be8-bdc9-2e4e-97b7-c000f817e6f5}%22:{%22name%22:%22Silverlight%20Plug-In%22,%22version%22:%224.0.51204.0%22,%22type%22:%22plugin%22,%22userDisabled%22:false,%22isCompatible%22:true,%22isBlocklisted%22:false},%22{a8ab8541-f4c0-5549-8a3b-05ac607ede20}%22:{%22name%22:%22Java%20Plug-In%202%20for%20NPAPI%20Browsers%22,%22version%22:%2213.4.0%22,%22type%22:%22plugin%22,%22userDisabled%22:false,%22isCompatible%22:true,%22isBlocklisted%22:false},%22{b936cf1a-5931-eb4c-958b-e91dee79320f}%22:{%22name%22:%22QuickTime%20Plug-in%207.6.6%22,%22version%22:%227.6.6%22,%22type%22:%22plugin%22,%22userDisabled%22:false,%22isCompatible%22:true,%22isBlocklisted%22:false}}
There is testpilot which gets installed by the beta release. Otherwise you have system-wide add-ons and plugins installed. Those are getting reported.

Shouldn't those be included in the fragment? Dave?
As mentioned in the original implementation bug 606386, we should only be counting extensions (not themes, plugins, etc.) for the purposes of this.

I don't care whether we exclude Test Pilot or not since it won't be bundled with the real version.
(Reporter)

Comment 4

7 years ago
Created attachment 514657 [details]
screenshot

Related bug is that clicking on listed themes(in personalized recommendation section) loads the "What are Add-ons?" module.

Once we stop allowing non-extensions in recommendations, this bug will be automatically fixed.
(Reporter)

Updated

7 years ago
Summary: Recommendations are shown when there no installed extensions → Only installed extensions should be used to calculate recommendations
(Assignee)

Comment 5

7 years ago
Fixed: https://github.com/jbalogh/zamboni/commit/ef9cdb6
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED

Updated

7 years ago
Whiteboard: [pickme]
Reopening; with Minefield, and Personas installed, on both preview/next, I see Personas showing up in the Recommended area.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Created attachment 514832 [details]
Screenshot of Personas showing up, with "null" in the Recommended area
http://pastebin.mozilla.org/1095731 has the GET request from preview.
(Assignee)

Comment 9

7 years ago
Are these existing recommendations? If you already have recommendations in localStorage, then you won't see any changes yet. If you install or remove an extension, do you still see Personas in your recommendations?
(In reply to comment #9)
> Are these existing recommendations? If you already have recommendations in
> localStorage, then you won't see any changes yet. If you install or remove an
> extension, do you still see Personas in your recommendations?

I removed an extension (should I try removing a Persona, too?), and yes: still seeing them show up as Recommended, after restart.
Spun off my apparently spurious comment 6, comment 7, comment 8 as bug 636527.

Chris, guess you can re-resolve this, now.
(In reply to comment #11)
> Chris, guess you can re-resolve this, now.

Can you please just close it yourself next time?
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → FIXED
(In reply to comment #12)
> (In reply to comment #11)
> > Chris, guess you can re-resolve this, now.
> 
> Can you please just close it yourself next time?

It's bad form for QA to resolve bugs as Fixed, typically, but yes.
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.