Implement Discovery Pane promos

RESOLVED FIXED in 5.12.12

Status

defect
P1
normal
RESOLVED FIXED
8 years ago
3 years ago

People

(Reporter: fligtar, Assigned: cvan)

Tracking

5.12.12
Dependency tree / graph

Details

Reporter

Description

8 years ago
Please implement the discovery pane promos from this PSD:

http://mozilla.seanmartell.com/addons/addon-pane-promoz.psd

The "First time?" one should only be displayed if the user has fewer than 3 add-ons installed. Ordering is managed by the admin tool.

Final copy to use will be posted below.

We need to launch these next Thursday 3/3
Target Milestone: 5.12.12 → 6.0.0
You can see the n-1 mockup of this at http://mozilla.seanmartell.com/engagement/addons-pane-promoz.jpg

The 3rd and 4th example aren't collections, but ads for other things.  Those can be hardcoded, but we want to be able to order them using the admin tool (https://addons.mozilla.org/en-US/firefox/discovery/modules).

This will have to land post freeze since we're short on time.
Assignee: nobody → jbalogh
Whiteboard: [post-freeze+]
Target Milestone: 6.0.0 → 5.12.12
(In reply to comment #0)
> Please implement the discovery pane promos from this PSD:
> 
> http://mozilla.seanmartell.com/addons/addon-pane-promoz.psd
> 
> The "First time?" one should only be displayed if the user has fewer than 3
> add-ons installed. Ordering is managed by the admin tool.
> 
> Final copy to use will be posted below.

Please give me the copy and images.
(In reply to comment #2)
> (In reply to comment #0)
> > Please implement the discovery pane promos from this PSD:
> > 
> > http://mozilla.seanmartell.com/addons/addon-pane-promoz.psd
> > 
> > The "First time?" one should only be displayed if the user has fewer than 3
> > add-ons installed. Ordering is managed by the admin tool.
> > 
> > Final copy to use will be posted below.
> 
> Please give me the copy and images.

I'm assuming cvan will be able to split out the psd.  If that's not the case, let me know.

Still need copy though.
Reporter

Comment 4

8 years ago
I talked with potch about this already but if cvan is doing the frontend, here's how the promos should scale:

* Rock Your Firefox - bg anchored to the left so RYF logo is always there
* First time - blue bg centered but left and right creatures anchored
* all others - bg anchored to center

Comment 5

8 years ago
Final Text:

1. Title: Starter Pack
Intro text: First time with Add-ons? Not to worry, here are three to get started.
• Yoono: Easily connect to your social networks, and share or comment on the page you're visiting. 
• Invisible Hand: A quick view to compare prices when you shop online or search for flights.
• ImTranslator: Translate content on the web from and into over 40 languages

2. Title: Featured.
Intro text: Mozilla’s Pick of the month: This month: Copy ShortURL
Body text: Copy ShortURL lets you instantly create a short URL for web pages that you visit, so you can easily share links with friends.
CTA: Add to Firefox button

3. Title: Firefox 4 Collection
Intro Text: We've chosen add-ons for you that are especially great for use with Firefox 4.

4. Title: Go Mobile
Intro text: Customize On The Go or Get Add-ons On The Go
Body: Visit firefox.com/m to get Firefox on your phone and personalize your browser anytime, anywhere. Easily discover and install add-ons right from the mobile Add-ons Manager.

5. Title: Dress up Firefox
Intro Text: St Patricks Day Personas
Body: Give your browser a personal touch by adding a persona to celebrate St. Patrick’s Day.
What are the urls for the new collections? Collections need to exist before we can point to them on the disco pane. There's first-timers, st. patrick's personas, and fx4.
Are we deleting the webdev and tester and shopper collections?
(In reply to comment #5)
> 2. Title: Featured.
> Intro text: Mozilla’s Pick of the month: This month: Copy ShortURL
> Body text: Copy ShortURL lets you instantly create a short URL for web pages
> that you visit, so you can easily share links with friends.
> CTA: Add to Firefox button

Are we writing our own copy for the text or does that come from the add-on's summary?

Comment 9

8 years ago
Hi Jeff, that's text we've come up with. Some of the summaries aren't all that suitable or are a bit too long, e.g copy shortURL: https://addons.mozilla.org/en-us/firefox/addon/copy-shorturl/
(In reply to comment #5)
> 4. Title: Go Mobile
> Intro text: Customize On The Go or Get Add-ons On The Go
> Body: Visit firefox.com/m to get Firefox on your phone and personalize your
> browser anytime, anywhere. Easily discover and install add-ons right from the
> mobile Add-ons Manager.

There's a button that says "Get Add-ons Made for Mobile" in the mock. Where does it point to and what is the real text?

Comment 11

8 years ago
That's the real text, and it should point to: https://addons.mozilla.org/en-US/mobile/?browse=featured
(In reply to comment #9)
> Hi Jeff, that's text we've come up with. Some of the summaries aren't all that
> suitable or are a bit too long, e.g copy shortURL:
> https://addons.mozilla.org/en-us/firefox/addon/copy-shorturl/

Thanks. I used your text for the summary now.
Reporter

Comment 13

8 years ago
(In reply to comment #6)
> What are the urls for the new collections? Collections need to exist before we
> can point to them on the disco pane. There's first-timers, st. patrick's
> personas, and fx4.

I created placeholders for a couple:
https://addons.mozilla.org/en-US/firefox/collections/mozilla/starter/
https://addons.mozilla.org/en-US/firefox/collections/mozilla/firefox-4/

St. Patrick's isn't a collection, it's just the 3 Personas.
http://www.getpersonas.com/en-US/persona/110250
http://www.getpersonas.com/en-US/persona/364649
http://www.getpersonas.com/en-US/persona/364654
(In reply to comment #13)
> St. Patrick's isn't a collection, it's just the 3 Personas.
> http://www.getpersonas.com/en-US/persona/110250
> http://www.getpersonas.com/en-US/persona/364649
> http://www.getpersonas.com/en-US/persona/364654

Why wouldn't it be a collection? You're asking me to display a collection of addons.
https://github.com/jbalogh/zamboni/commit/a29cc17 

=> cvan unless potch wants to take it.
Assignee: jbalogh → cwiemeersch
Depends on: 636624
(In reply to comment #0)
> The "First time?" one should only be displayed if the user has fewer than 3
> add-ons installed. Ordering is managed by the admin tool.

Fewer than 3 extensions or any 3 add-ons?
Reporter

Comment 17

8 years ago
extensions
this is going to land tonight
https://github.com/jbalogh/zamboni/commit/7491870
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Whiteboard: [post-freeze+] → [post-freeze+][pickme]
Reporter

Comment 20

8 years ago
These look awesome, thanks!

The St. Patrick's Day collection is here: https://addons.mozilla.org/en-US/firefox/collections/mozilla/st-patricks-day/
| 666627 | c2a2ba78-9e11-48f1-99ef-54b6d9c50475 | 

Also, it looks like the Rock Your Firefox collection is the old style instead of the new one?
Reporter

Comment 21

8 years ago
Couple other issues:
1) at certain widths I see gray vertical bars on the sides: http://grab.by/9g1x

2) I see a blank gray promo where the Starter Collection should be when cycling through the entire set.

3) The add-ons are using their own summaries, when they should be using the editorialized summaries we provided.
(In reply to comment #20)
> Also, it looks like the Rock Your Firefox collection is the old style instead
> of the new one?

The style of the RYFF collection in the Photoshop file matches that of the current style on the disco pane. Was there a different style for it?
Reporter

Comment 23

8 years ago
(In reply to comment #22)
> (In reply to comment #20)
> > Also, it looks like the Rock Your Firefox collection is the old style instead
> > of the new one?
> 
> The style of the RYFF collection in the Photoshop file matches that of the
> current style on the disco pane. Was there a different style for it?

Yeah, you have some weird layers going on. Make sure RYFF is showing. It should look like this, with the lines: http://grab.by/9g5z
https://github.com/cvan/zamboni/commit/691d7af

All issues (including new RYFF style) have been addressed except:

(In reply to comment #21)
> 1) at certain widths I see gray vertical bars on the sides: http://grab.by/9g1x
> 
> 2) I see a blank gray promo where the Starter Collection should be when cycling
> through the entire set.
Reporter

Comment 25

8 years ago
Thanks; I actually can't reproduce those anymore anyway. I'll file a separate bug for other tweaks.
Whiteboard: [post-freeze+][pickme]
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.