Flash plugin: Redraw problem (background?) shines through

RESOLVED INCOMPLETE

Status

()

Core
Plug-ins
RESOLVED INCOMPLETE
7 years ago
8 months ago

People

(Reporter: Tobias Burnus, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Created attachment 514616 [details]
Low-res screenshot

That's with openSUSE's MozillaFirefox-4.0b11-2.2.x86_64 and flash-player-10.2.152.26-1.1.i586

If one goes to 
http://www.faz.net/s/Rub87AD10DD0AE246EF840F23C9CBCBED2C/Doc~E6133CB15FF994801B7A40623A4C36524~ATpl~Ecommon~SMed.html

the Flash page is nicely rendered, however, if one moves over the country names (buttons), those are painted white. And the boxes which appear, when one clicks on those buttons also show redraw problems. Cf. attached screenshot.

If one forces a redraw, e.g., by moving away to another tab and back, the result is OK again. Worked also with Firefox 3.6 w/o problems.

The same problem can be observed on other sites with interactive Flash, while most simpler Flash such as Youtube work.
Tobias, does this work with the latest Minefield?
(Reporter)

Comment 2

7 years ago
(In reply to comment #1)
> Tobias, does this work with the latest Minefield?

I didn't use Minefield, but I have now updated to MozillaFirefox-4.0b12-197.1.x86_64.rpm, which as b12 was tagged yesterday, should be new enough.

Using b12, the situation has much improved, but it still not completely right. Moving with the mouse over those country-name buttons (w/o clicking) still leaves them as white rectangles (cf. attachment), however, if the mouse pointer leaves the area of the Flash plugin, Flash redraws.

If one clicks a button, the button is - after releasing the mouse - also drawn correctly in the down state; but if one now moves out of the button, it is drawn again as white rectangle.

Regarding boxes, which pop up when clicking: One sees a large white rectangle flashing up, but then the box is usually drawn correctly. However, in particular, if an already enabled button is clicked again, the box has a similar drawing problems as the attachment 514616 [details] shows: The bottom part of the box is covered by a white rectangle.

Comment 3

8 months ago
Resolving old bugs which are likely not relevant any more, since NPAPI plugins are deprecated.
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.