Ctrl+Shift+C Shortcut key to open calendar is destructive "Mark all read"

RESOLVED FIXED in 1.0b4

Status

Calendar
Lightning: SeaMonkey Integration
RESOLVED FIXED
7 years ago
5 years ago

People

(Reporter: Bill Davidsen, Assigned: Philip Chee)

Tracking

Details

(Whiteboard: [good first bug])

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (X11; Linux i686; rv:2.0b12pre) Gecko/20110221 Firefox/4.0b12pre SeaMonkey/2.1b3pre
Build Identifier: Mozilla/5.0 (X11; Linux i686; rv:2.0b12pre) Gecko/20110221 Firefox/4.0b12pre SeaMonkey/2.1b3pre

Installing Lightning on Seamonkey (2.0 or 2.1b) the "Events and Tasks" drop down shows "Ctrl+Shift+C" as the shortcut key. This sequence marks all items in the current folder as read! This permanently ends the ability to read unread mail for those messages.

NOTE: this is a menu error, the shortcut key sequence shown in the menu is wrong, not the functioning of the shortcut. Users who don't recognize the shortcut as wrong and use it as suggested get unexpected results.



Reproducible: Always

Actual Results:  
Menu tells the user to use a destructive shortcut to open the calendar tab

Expected Results:  
Menu would offer correct information, or show no shortcut

A user found this in current release 2.0.11 and I verified it in 2.1b as well. I recognized the shortcut BEFORE I tried it, the user didn't.

I marked this as "critical" because it does cause loss of important information and is in the production Seamonkey. Please don't push this off as a Lightning bug, Seamonkey needs the calendar for any serious use.
(Assignee)

Comment 1

7 years ago
What does Thunderbird 3.3 use for Mark-All-Read?

Comment 2

7 years ago
(In reply to comment #1)
> What does Thunderbird 3.3 use for Mark-All-Read?

Shift+C.   SM should be using the same thing. (and not Ctrl+Shift+C)

On thunderbird windows I can't reproduce Ctrl+Shift+C as marking all messages.

I would think if this affected all lightning users that the problem would have surfaced prior to this. Does reproduce only on linux or Mac?  In safe mode/without lighting?


(affirming completeness in summaries is a good thing)
Summary: Shortcut key to open calendar is destructive "Mark all read" → Ctrl+Shift+C Shortcut key to open calendar is destructive "Mark all read"
(Assignee)

Comment 3

7 years ago
Thunderbird fixed this in:
Bug 477091: shortcuts for opening calendar or tasks tab don't work, new shortcuts required.
<http://hg.mozilla.org/comm-central/rev/129da8379d42>

But nobody thought to tell us about this. :P
Status: UNCONFIRMED → NEW
Component: MailNews: General → MailNews: Message Display
Ever confirmed: true
OS: Linux → All
QA Contact: mail → message-display
Hardware: x86 → All
Whiteboard: [good first bug]
Version: unspecified → Trunk
(Reporter)

Comment 4

7 years ago
(In reply to comment #2)
> (In reply to comment #1)
> > What does Thunderbird 3.3 use for Mark-All-Read?
> 
> Shift+C.   SM should be using the same thing. (and not Ctrl+Shift+C)
> 
SM has been using Ctrl-Shift keys for a long time, and please understand that the bug is not in the function, it's in the menu. The menu tells the users about a shortcut which does something destructive, and all that needs to be done is to take the shortcut hint off the menu, or change it to something which works. Only the "bad advice" is a problem.

> On thunderbird windows I can't reproduce Ctrl+Shift+C as marking all messages.
> 
It doesn't, I think it actually does pop a calendar tab.

> I would think if this affected all lightning users that the problem would have
> surfaced prior to this. Does reproduce only on linux or Mac?  In safe
> mode/without lighting?
> 
The shortcut is actually working correctly, but it's the WRONG shortcut. We just need to stop telling people to shoot themselves in the foot! Something like a recipe which specifies arsenic when it meant aspic, if you don't know it's dangerous it causes problems.
(Assignee)

Comment 5

7 years ago
critical=>major since Edit->Undo Mark All Read (CTRL-Z) is available.
(Assignee)

Comment 6

7 years ago
Untested suggestion:

/calendar/lightning/jar.mn:
% overlay chrome://lightning/content/messenger-overlay-sidebar.xul chrome://lightning/content/suite-overlay-sidebar.xul application={92650c4d-4b8e-4d2a-b7eb-24ecf4f6b63a}

/calendar/lightning/content/suite-overlay-sidebar.xul:
    <keyset id="calendar-keys">
      <key id="openLightningKey"
           modifiers="shift"/>
    </keyset>

Would this be acceptable to the Calendar team?
Sounds good to me, but you'll probably have more luck just specifying the inner key in the xul file, i.e just

<key id="openLightningKey" modifiers="shift"/>
(Assignee)

Comment 8

7 years ago
While working on this I noticed that Lightning uses
CTRL-SHIFT-D to open the tasks tab, and
CTRL-D to create a new task.

Unfortunately this clashes with SeaMonkey which uses these shortcuts for Get New Messages, and Get New Messages for All Accounts.

Is ALT-D and ALT-SHIFT-D taken? Or do we just remove the shortcut keys for these two items?
(Reporter)

Comment 9

7 years ago
(In reply to comment #8)
> While working on this I noticed that Lightning uses
> CTRL-SHIFT-D to open the tasks tab, and
> CTRL-D to create a new task.
> 
> Unfortunately this clashes with SeaMonkey which uses these shortcuts for Get
> New Messages, and Get New Messages for All Accounts.
> 
> Is ALT-D and ALT-SHIFT-D taken? Or do we just remove the shortcut keys for
> these two items?

That was very much was I had in mind when I reported this bug, the error is that the menu suggests the wrong shortcut, why not just take the shortcut off the menu? Not that I have anything against ALT-C for calendar, but just taking the wrong info off the menu would solve the problem as far as I'm concerned.

This is like the menu which said Shift-Cntl-K ended a link, when in fact it started the spell checker. I reported that against 1.0.6 and it was fixed in 2.0b, finally. There's no need to change anything but delete the bad info on the menu.
(Assignee)

Comment 10

7 years ago
Bill, removing the visual indication from the menu doesn't remove the shortcut which will still be active. I am proposing removing the shortcut(s) as well.
(Reporter)

Comment 11

7 years ago
(In reply to comment #10)
> Bill, removing the visual indication from the menu doesn't remove the shortcut
> which will still be active. I am proposing removing the shortcut(s) as well.

But the shortcut is USEFUL! It's the shortcut to "mark all read" it just has nothing to do with calendar. All we need to do is stop telling people to do the wrong thing for calendar, the shortcut works exactly as intended. The shortcut to the function people have been using for years is fine as is.

Why is this so hard to see? There is bad information in the menu, take it out. Then people don't go to the menu and decide to use the "faster way" to get a calendar. The error is in the menu, it should be fixed there, defining a new shortcut for calendar is optional.
(Assignee)

Comment 12

7 years ago
Sorry I meant removing the *Lightning* shortcut. At the moment the SeaMonkey CTRL-SHIFT-C wins out but under certain circumstances e.g. if you are using KeyConfig to reorder your shortcut keys, the lightning version of CTRL-SHIFT-C might win out. I'm thinking of removing both the visual indication in the Lightning menu as well as the underlying Lightning shortcut so that nothing interferes with the native SeaMonkey shortcut. Sorry for the confusion.
> I'm thinking of removing both the visual indication in the Lightning menu as
> well as the underlying Lightning shortcut so that nothing interferes with the
> native SeaMonkey shortcut.

That seems to be the most plausible course, yes.
(Assignee)

Updated

7 years ago
Assignee: nobody → philip.chee
Severity: critical → normal
Status: NEW → ASSIGNED
Component: MailNews: Message Display → Lightning: SeaMonkey Integration
Product: SeaMonkey → Calendar
QA Contact: message-display → lightning-seamonkey
(Assignee)

Comment 14

7 years ago
Created attachment 516264 [details] [diff] [review]
Patch v1.0 Remove shortcuts when in SeaMonkey.

> Karsten Düsterloh      2011-03-01 23:21:39 PST
> 
>> I'm thinking of removing both the visual indication in the Lightning menu as
>> well as the underlying Lightning shortcut so that nothing interferes with the
>> native SeaMonkey shortcut.
> 
> That seems to be the most plausible course, yes.

Instead of desperately chasing down increasing rare unused shortcut keys in SeaMonkey MailNews, I'll just remove the main Lightning shortcuts when installed in SeaMonkey. And even if I fix the shortcuts in en-US it's likely one or more SeaMonkey locales will still have this problem.
Attachment #516264 - Flags: review?(philipp)
Comment on attachment 516264 [details] [diff] [review]
Patch v1.0 Remove shortcuts when in SeaMonkey.

r=philipp
Attachment #516264 - Flags: review?(philipp) → review+
(Assignee)

Comment 16

7 years ago
Pushed to comm-central:
http://hg.mozilla.org/comm-central/rev/6f848212dca4
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Trunk
(Assignee)

Updated

5 years ago
Duplicate of this bug: 514512
You need to log in before you can comment on or make changes to this bug.