Links in event postings for 'Event Details' & 'Read More' are not properly hyperlinked

VERIFIED FIXED

Status

quality.mozilla.org
Website
P2
normal
VERIFIED FIXED
7 years ago
7 years ago

People

(Reporter: aaronmt, Unassigned)

Tracking

({regression})

Details

(URL)

(Reporter)

Description

7 years ago
With the Wordpress 3.1 upgrade there appears to be a regression in event postings with the 'Event Details' and 'Read More' links within each event posting. This is prohibiting one from viewing such details.

Example: http://quality.mozilla.org/events/2011/02/18/mobile-firefox-4-beta-testday-february-25th/
This might be a Wordpress 3.1 compatibility issue with the Events Calendar plugin we use for events - http://wordpress.org/extend/plugins/the-events-calendar/.
(In reply to comment #1)
> This might be a Wordpress 3.1 compatibility issue with the Events Calendar
> plugin we use for events -
> http://wordpress.org/extend/plugins/the-events-calendar/.

I suspect that as well. The Events Calendar seems to be usurping the "/events/" part of the permalink URL, which is only there because QMO includes the category in its permalink structure. What should be a single post in the "events" category instead gets treated as the main events page, which isn't meant to show full posts. It worked before the upgrade so evidently something changed in WP 3.1 that has this effect on The Events Calendar. 

Removing the category from the permalink mask makes event permalinks work again and solves the problem, but at the cost of changing every existing permalink and thus breaking any old bookmarks. Maybe we can formulate a redirect that would keep the old URLs functional. Or we can hope for an update to The Events Calendar very soon.
I'm happy to break permalinks if necessary to have a final solution to this issue. Right now, we're a bit blocked on using our events calendar until this is fixed.
Others are reporting the same issue (http://wordpress.org/support/topic/plugin-the-events-calendar-compatibility-with-wordpress-31) and it is indeed related to the way WP3.1 handles category redirects. Ryan Boren (WP developer) has a quick fix that is working for me, without changing permalinks. 

It requires one minor change in the plugin's code, which I've done in r83446 so we just need that pushed to production.

Since this is an edit to third-party code, the change may be overwritten next time The Events Calendar releases an update. But hopefully the next update will fix this bug anyway so it won't be a problem, but we'll still want to double-check it.
Assignee: nobody → server-ops
Your fix should have rolled out to quality-new.stage.mozilla.com five minutes after checkin. Looking there on the past events page (http://quality-new.stage.mozilla.com/category/events/past), the "event details" and "read more" links appear to work now.

What do we need to do to get this pushed to the live site?
(In reply to comment #5)
 
> What do we need to do to get this pushed to the live site?

We just need server-ops to push r83446 from SVN to production. I've reassigned this bug to server-ops already but maybe we should escalate it to critical and bump it up the queue.
Upping priority to p2. I believe that is "within 24 hours."
Priority: -- → P2
(In reply to comment #6)
> (In reply to comment #5)
> 
> > What do we need to do to get this pushed to the live site?
> 
> We just need server-ops to push r83446 from SVN to production. I've reassigned
> this bug to server-ops already but maybe we should escalate it to critical and
> bump it up the queue.

Can we have please have a new bug for this please, since this is a production push. 

Mixing bugs from QA -> ServerOps is not a good idea.


(In reply to comment #7)
> Upping priority to p2. I believe that is "within 24 hours."

IT users Blocker, Critical and Major (immediate, 8 hours and 24 hours) and we don't follow the P's (just for future reference :) )
Assignee: server-ops → nobody
Fixed with r83569 in production (bug 637693)
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(In reply to comment #8)
> > Upping priority to p2. I believe that is "within 24 hours."
> 
> IT users Blocker, Critical and Major (immediate, 8 hours and 24 hours) and we
> don't follow the P's (just for future reference :) )

 Yes but I see no field for that in the bug so it is kind of hard to set!
Looks great now. Thanks!

Tested with:
http://quality.mozilla.org/events/2011/02/28/add-ons-compatibility-and-add-ons-manager-testday-march-4th/
Status: RESOLVED → VERIFIED
Hardware: x86 → All
You need to log in before you can comment on or make changes to this bug.