Personalized recommendations should only recommend compatible add-ons

RESOLVED WONTFIX

Status

addons.mozilla.org Graveyard
Public Pages
P1
major
RESOLVED WONTFIX
8 years ago
3 years ago

People

(Reporter: krupa, Assigned: jbalogh)

Tracking

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

8 years ago
Created attachment 514653 [details]
screenshot

Firefox 4.0b11

steps to reproduce:
1.Tools->Add-ons
2. Check that all add-ons listed under Personalized recommendations are compatible with Firefox 4.0b11

observed behavior:
One of the recommendations is "MementoFox" which is not compatible with Firefox 4.0b11.

https://addons.allizom.org/en-US/firefox/discovery/addon/mementofox/?src=discovery-personalrec
(Reporter)

Comment 1

8 years ago
Created attachment 514654 [details]
mementofox in recommendations
Assignee: nobody → jbalogh
Priority: -- → P1
(Assignee)

Updated

8 years ago
Target Milestone: 5.12.11 → 5.12.12
(Assignee)

Comment 3

8 years ago
https://github.com/jbalogh/zamboni/commit/3360275
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Assignee)

Updated

8 years ago
Duplicate of this bug: 636919
(Reporter)

Comment 5

8 years ago
Created attachment 516354 [details]
screenshot

Firefox 4.0b12/MACOSX

'Restartless App Button Quit' is one of the add-ons listed under recommendations. This add-on is not compatible with my platform.

(This is after clearing localStorage)
(Reporter)

Updated

8 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 6

8 years ago
(In reply to comment #5)
> Firefox 4.0b12/MACOSX

Please include a URL (without the add-ons hash).
(Reporter)

Comment 7

8 years ago
without the add-ons hash:
https://addons-next.allizom.org/en-US/firefox/discovery/pane/4.0b12/Darwin


entire URL:
https://addons-next.allizom.org/en-US/firefox/discovery/pane/4.0b12/Darwin#{%22langpack-ca-valencia@firefox.mozilla.org%22:{%22name%22:%22Catal%C3%A0%20%28valenci%C3%A0%29%20Language%20Pack%22,%22version%22:%223.6%22,%22type%22:%22locale%22,%22userDisabled%22:false,%22isCompatible%22:false,%22isBlocklisted%22:false},%22xssme@security.compass%22:{%22name%22:%22XSS%20Me%22,%22version%22:%220.4.4%22,%22type%22:%22extension%22,%22userDisabled%22:false,%22isCompatible%22:false,%22isBlocklisted%22:false},%22{9c51bd27-6ed8-4000-a2bf-36cb95c0c947}%22:{%22name%22:%22Tamper%20Data%22,%22version%22:%2211.0.1%22,%22type%22:%22extension%22,%22userDisabled%22:false,%22isCompatible%22:false,%22isBlocklisted%22:false},%22{a6fd85ed-e919-4a43-a5af-8da18bda539f}%22:{%22name%22:%22Selenium%20IDE%22,%22version%22:%221.0.4%22,%22type%22:%22extension%22,%22userDisabled%22:false,%22isCompatible%22:false,%22isBlocklisted%22:false},%22{7eb3f691-25b4-4a85-9038-9e57e2bcd537}%22:{%22name%22:%22XPath%20Checker%22,%22version%22:%220.4.4%22,%22type%22:%22extension%22,%22userDisabled%22:false,%22isCompatible%22:true,%22isBlocklisted%22:false},%22csscoverage@spaghetticoder.org%22:{%22name%22:%22CSS%20Usage%22,%22version%22:%220.2.2%22,%22type%22:%22extension%22,%22userDisabled%22:false,%22isCompatible%22:false,%22isBlocklisted%22:false},%22compatibility@addons.mozilla.org%22:{%22name%22:%22Add-on%20Compatibility%20Reporter%22,%22version%22:%220.7%22,%22type%22:%22extension%22,%22userDisabled%22:false,%22isCompatible%22:true,%22isBlocklisted%22:false},%22{e968fc70-8f95-4ab9-9e79-304de2a71ee1}%22:{%22name%22:%22User%20Agent%20Switcher%22,%22version%22:%220.7.3%22,%22type%22:%22extension%22,%22userDisabled%22:false,%22isCompatible%22:true,%22isBlocklisted%22:false},%22{c45c406e-ab73-11d8-be73-000a95be3b12}%22:{%22name%22:%22Web%20Developer%22,%22version%22:%221.1.9%22,%22type%22:%22extension%22,%22userDisabled%22:false,%22isCompatible%22:true,%22isBlocklisted%22:false},%22jid0-t3eeRQgGANLCH9c50lPqcTDuNng@jetpack%22:{%22name%22:%22Add-on%20Builder%20Helper%22,%22version%22:%220.0.17%22,%22type%22:%22extension%22,%22userDisabled%22:false,%22isCompatible%22:false,%22isBlocklisted%22:false},%22jid0-FtPIaGgLHC4eT63AcejhHnPjbms@jetpack%22:{%22name%22:%22Where%20Am%20O?%22,%22version%22:%221.0.rev55%22,%22type%22:%22extension%22,%22userDisabled%22:true,%22isCompatible%22:true,%22isBlocklisted%22:false},%22jid0-bqvbKuqYlwQo2zzFD8qEK0nDGlo@jetpack%22:{%22name%22:%22Mobilify%22,%22version%22:%221.0b%22,%22type%22:%22extension%22,%22userDisabled%22:false,%22isCompatible%22:true,%22isBlocklisted%22:false},%22{9AB56F4F-4EC8-5e87-97AF-5336180634FE}%22:{%22name%22:%22bekaaraan%22,%22version%22:%221.4%22,%22type%22:%22extension%22,%22userDisabled%22:false,%22isCompatible%22:true,%22isBlocklisted%22:false},%22{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}%22:{%22name%22:%22Adblock%20Plus%22,%22version%22:%221.1.2%22,%22type%22:%22extension%22,%22userDisabled%22:false,%22isCompatible%22:false,%22isBlocklisted%22:false},%22{972ce4c6-7e08-4474-a285-3208198ce6fd}%22:{%22name%22:%22Default%22,%22version%22:%224.0b12%22,%22type%22:%22theme%22,%22userDisabled%22:false,%22isCompatible%22:true,%22isBlocklisted%22:false},%22inspector@mozilla.org%22:{%22name%22:%22DOM%20Inspector%22,%22version%22:%222.0.8%22,%22type%22:%22extension%22,%22userDisabled%22:false,%22isCompatible%22:true,%22isBlocklisted%22:false},%22{8f8fe09b-0bd3-4470-bc1b-8cad42b8203a}%22:{%22name%22:%22Live%20HTTP%20headers%22,%22version%22:%220.16%22,%22type%22:%22extension%22,%22userDisabled%22:false,%22isCompatible%22:false,%22isBlocklisted%22:false},%22{6F0976E6-26F3-4AFE-BBEC-9E99E27E4DF3}%22:{%22name%22:%22Fire.fm%22,%22version%22:%221.4.13%22,%22type%22:%22extension%22,%22userDisabled%22:false,%22isCompatible%22:true,%22isBlocklisted%22:false},%22sharing@addons.mozilla.org%22:{%22name%22:%22Add-on%20Collector%22,%22version%22:%221.2.1%22,%22type%22:%22extension%22,%22userDisabled%22:false,%22isCompatible%22:false,%22isBlocklisted%22:false},%22{cca2071d-89ee-614c-99ea-7b85a64d22dc}%22:{%22name%22:%22Picasa%22,%22version%22:%221.0%22,%22type%22:%22plugin%22,%22userDisabled%22:false,%22isCompatible%22:true,%22isBlocklisted%22:false},%22{cc42c239-c0fa-694c-b2b4-45f0d9d38bf5}%22:{%22name%22:%22iPhotoPhotocast%22,%22version%22:%227.0%22,%22type%22:%22plugin%22,%22userDisabled%22:false,%22isCompatible%22:true,%22isBlocklisted%22:false},%22{92840b44-250a-7143-a5fa-720eaa864962}%22:{%22name%22:%22Java%20Plug-In%202%20for%20NPAPI%20Browsers%22,%22version%22:%2213.3.0%22,%22type%22:%22plugin%22,%22userDisabled%22:false,%22isCompatible%22:true,%22isBlocklisted%22:false},%22{430be769-8f5e-6444-a427-f5c7a16052c6}%22:{%22name%22:%22Silverlight%20Plug-In%22,%22version%22:%224.0.51204.0%22,%22type%22:%22plugin%22,%22userDisabled%22:false,%22isCompatible%22:true,%22isBlocklisted%22:false},%22{ead980d9-02d7-8e40-8aa4-bb87edd90747}%22:{%22name%22:%22Shockwave%20Flash%22,%22version%22:%2210.2.152.26%22,%22type%22:%22plugin%22,%22userDisabled%22:false,%22isCompatible%22:true,%22isBlocklisted%22:false},%22{f9d061ec-c3c9-2441-bf60-f559658dbfa7}%22:{%22name%22:%22QuickTime%20Plug-in%207.6.6%22,%22version%22:%227.6.6%22,%22type%22:%22plugin%22,%22userDisabled%22:false,%22isCompatible%22:true,%22isBlocklisted%22:false}}
(Assignee)

Comment 8

8 years ago
https://github.com/jbalogh/zamboni/commit/0a1da07 

Please don't paste disco pane URLs directly into bugs. It's awful to look at and bugzilla ruins the formatting.
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → FIXED

Comment 9

8 years ago
I'd be less awful and much shorter if the JSON blob didn't contain flags that are set to defaults. If every "userDisabled":false, "isCompatible":true, and "isBlocklisted":false were cut out then it would be far less of a mess to send to the server. Just use undefined instead of false for booleans and the stringified object won't contain them. (isCompatible could also be changed to isIncompatible to allow that to not need sending the majority of the time either) That would cut the length of the JSON blob pretty much in half for most people and not lose any information.

(where would I file this bug, in the client side Addon Manager component?)
(Reporter)

Comment 10

8 years ago
Checked in a bunch of different profiles and I do not get any incompatible recommendations anymore. Marking this as fixed.
Status: RESOLVED → VERIFIED
(Reporter)

Updated

8 years ago
Whiteboard: [pickme]
(Assignee)

Updated

8 years ago
Whiteboard: [pickme]

Comment 11

6 years ago
Incompatible addons found again in "Recommended for you" section  : http://screencast.com/t/VFxLPJQkb
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
Thanks for filing this.  Due to resource constraints we are closing bugs which we won't realistically be able to fix.  If you have a patch that applies to this bug please reopen.

For more info see http://micropipes.com/blog/2014/09/24/the-great-add-on-bug-triage/
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago4 years ago
Resolution: --- → WONTFIX
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.