If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Sync: bookmarks failed: NS_ERROR_MALFORMED_URI

RESOLVED DUPLICATE of bug 622657

Status

Cloud Services
Firefox Sync: Backend
RESOLVED DUPLICATE of bug 622657
7 years ago
5 years ago

People

(Reporter: chris.moore, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13 ( .NET CLR 3.5.30729; .NET4.0C)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13 ( .NET CLR 3.5.30729; .NET4.0C)

Bookmark sync returns the following error every time.

Error while syncing
Sync encounter an error while syncing: unknown
error. Sync will automaticly retry this action

then it jsut error again and never backups bookmarks etc



Reproducible: Always

Steps to Reproduce:
1.tool -> sync ->sync now
2.status bar shows error
3.click error anc close
Please open about:sync-log (enter it as URL), save the log to a file and attach it here using the "add an attachment" link
Component: General → Firefox Sync: Backend
Product: Firefox → Mozilla Services
QA Contact: general → sync-backend
(Reporter)

Comment 2

7 years ago
Created attachment 514755 [details]
about:sync-log - as requested

about:sync-log as requested
You have a bookmark with a malformed URI.

If you go to about:config, change the value of 

  services.sync.log.logger.engine.bookmarks

to 

  Trace

Relaunch Firefox, run a sync, and attach about:sync-log to this bug again. That will allow us to see which record is causing the problem.

Thanks!
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Sync → Sync: bookmarks failed: NS_ERROR_MALFORMED_URI
(Reporter)

Comment 4

7 years ago
Created attachment 514845 [details]
about:sync-log with trace - as requested
(In reply to comment #4)
> Created attachment 514845 [details]
> about:sync-log with trace - as requested

Chris, did you set to trace level *and* restart Firefox before syncing again? I don't see any trace messages in that log.
(Reporter)

Comment 6

7 years ago
I did set services.sync.log.logger.engine.bookmarks to trace and shut down firefox and restarted.

I double clicked services.sync.log.logger.engine.bookmarks and changed the value to trace ... is that correct?

I think I have fixed it ... I have un ticked all the items to sync (bookmarks, tabs, history, etc) then synced then re ticked every thing and synced again .... 

So far no error...
(In reply to comment #6)
> I did set services.sync.log.logger.engine.bookmarks to trace and shut down
> firefox and restarted.
> 
> I double clicked services.sync.log.logger.engine.bookmarks and changed the
> value to trace ... is that correct?

It must be Trace (capital T).
(Reporter)

Comment 8

7 years ago
Created attachment 514867 [details]
about:sync-log with Trace - as requested

hopefully this is correct
(In reply to comment #8)
> Created attachment 514867 [details]
> about:sync-log with Trace - as requested
> 
> hopefully this is correct

It is, but unfortunately the log roller kicked in after printing what we're looking for. Would you mind doing another sync and posting the contents of

  about:sync-log.1

? Sorry to be a pain. Many of the features that would make debugging or resolving this easier (disabling log rolling, skipping over bad records...) aren't available in Sync 1.6.3.

(If you switch to Firefox 4 beta, you should see sync complete even with the error, and there's an easy way to find out which record failed.)

Thanks!
(Reporter)

Comment 10

7 years ago
Created attachment 515035 [details]
about:sync-log.1 - as requested
Duplicate of this bug: 626371
Here's a modern failure:

1318429157188   Sync.Engine.Bookmarks      INFO  135 outgoing items pre-reconciliation
1318429157683   Sync.Engine.Bookmarks      WARN  Got exception "Component returned failure code: 0x804b000a (NS_ERROR_MALFORMED_URI) [nsINavBookmarksService.getBookmarkURI] Stack trace: _buildGUIDMap()@resource:///modules/services-sync/engines/bookmarks.js:291 < resource:///modules/services-sync/engines/bookmarks.js:401 < _mapDupe()@resource:///modules/services-sync/engines/bookmarks.js:358 < _createRecord()@resource:///modules/services-sync/engines/bookmarks.js:441 < SyncEngine__isEqual()@resource://services-sync/engines.js:898 < SyncEngine__reconcile()@resource://services-sync/engines.js:947 < resource://services-sync/engines.js:765 < resource:///modules/services-sync/record.js:828 < Channel_onDataAvail()@resource://services-sync/resource.js:569" building GUID map. Skipping all other incoming items.
OS: Windows Vista → All
Hardware: x86 → All
I hit this recently. Problem went away after about 12 hours.

rnewman had me run the following from the web console after loading a chrome page such as about:config

Components.utils.import("resource://services-sync/engines.js");
Components.utils.import("resource://gre/modules/PlacesUtils.jsm");
let bme = Engines.get("bookmarks");
let bms = bme._store;
let ids = bms.getAllIDs();
for (let id of Object.keys(ids)) {
  let i = bms.idForGUID(id);
  try {
    if (PlacesUtils.bookmarks.getItemType(i) == PlacesUtils.bookmarks.TYPE_BOOKMARK) {
      PlacesUtils.bookmarks.getBookmarkURI(i);
    }

no ID * failed: messages were shown.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 622657
You need to log in before you can comment on or make changes to this bug.