bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

[traceback] IntegrityError: hashtag is required to create xpi

RESOLVED FIXED in Builder 0.9.2

Status

addons.mozilla.org Graveyard
Add-on Builder
P4
normal
RESOLVED FIXED
8 years ago
4 years ago

People

(Reporter: clouserw, Assigned: zalun)

Tracking

unspecified
Builder 0.9.2

Details

(URL)

(Reporter)

Description

8 years ago
Traceback (most recent call last):

 File "/data/amo_python/www/builder/flightdeck/vendor/lib/python/django/core/handlers/base.py", line 100, in get_response
   response = callback(request, *callback_args, **callback_kwargs)

 File "/data/amo_python/www/builder/flightdeck/apps/xpi/views.py", line 73, in prepare_download
   revision.build_xpi(hashtag=hashtag)

 File "/data/amo_python/www/builder/flightdeck/apps/jetpack/models.py", line 1027, in build_xpi
   raise IntegrityError('hashtag is required to create xpi')

IntegrityError: hashtag is required to create xpi
(Reporter)

Updated

8 years ago
Target Milestone: Builder 0.9.1 → Builder 0.9.2
Zalun, I assigned this to you, but I'm not sure if this is still an issue, I don't see this error anymore in our exceptions emails. If you can confirm this is fixed, just close it out.
Assignee: nobody → zaloon
(Assignee)

Comment 2

7 years ago
We can always reopen it if there is an edge case
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.