Closed Bug 636521 Opened 10 years ago Closed 10 years ago

Mailboxes won't compact if they are large, >4GB

Categories

(Thunderbird :: Folder and Message Lists, defect)

x86
Linux
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 608449

People

(Reporter: the_mix_room, Unassigned)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.13) Gecko/20101206 Ubuntu/10.04 (lucid) Firefox/3.6.13
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.9pre) 

When the Inbox is full, a message prompting the user to remove mail is displayed. 
If the Inbox is too large, compacting does not seem to work. 
The inbox in questions is 5.6 GB large. When viewing the Inbox with 'cat Inbox | head' old email which should have been deleted can still be seen. 
Since compacting does not work, and no new Email can be downloaded when the Inbox is full, Thunderbird is not usable.
(Can be worked around by moving the Inbox to a new location, but this is not a suitable solution) 

Reproducible: Always

Steps to Reproduce:
1. Download lots of email
2. Check size (ls -lh)
3. Erase some in Thunderbird 
4. Compact 
5. Check size (ls -lh) 
Actual Results:  
1st ls -l: 5964705825
( remove all but 11 small emails  and compacted several times) 
2nd ls -l: 5964705825

Expected Results:  
The Inbox should be substantially smaller.
this is fixed in version 3.1.7 or newer
Summary: Mailboxes won't compact if they are large → Mailboxes won't compact if they are large, >4GB
Whiteboard: dupeme
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 608449
Whiteboard: dupeme
You need to log in before you can comment on or make changes to this bug.