Closed Bug 636599 Opened 11 years ago Closed 11 years ago

Firefox Sync should not synchronize "autoscroll" pref (whose default value varies between platforms)

Categories

(Firefox :: Sync, defect)

x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 636176

People

(Reporter: dholbert, Unassigned)

Details

Autoscroll is preffed off by default on linux (and other non-mac Unix variants):
> 227 #ifdef UNIX_BUT_NOT_MAC
> 228 pref("general.autoScroll", false);
> 229 #else
> 230 pref("general.autoScroll", true);
> 231 #endif
http://mxr.mozilla.org/mozilla-central/source/browser/app/profile/firefox.js?mark=227-231#227

However, this pref is configured to be automatically synchronized by Sync:

> 981 // Preferences to be synced by default
[...]
> 1015 pref("services.sync.prefs.sync.general.autoScroll", true);
http://mxr.mozilla.org/mozilla-central/source/browser/app/profile/firefox.js?mark=1015-1015#981

...so if you have both Windows & Linux machines connected via Sync, then one of them will overwrite the other's default.  (I just noticed that this pref had magically become set on my Linux machine, after I'd added a new Windows machine (with default settings) to my sync pool).
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 636176
Component: Firefox Sync: Backend → Sync
Product: Cloud Services → Firefox
You need to log in before you can comment on or make changes to this bug.