Last Comment Bug 636650 - Stop redefining STAGE_DIST in browser/locales/Makefile.in, l10n.mk is enough
: Stop redefining STAGE_DIST in browser/locales/Makefile.in, l10n.mk is enough
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Build Config (show other bugs)
: unspecified
: x86 Windows XP
: -- normal (vote)
: ---
Assigned To: Justin Wood (:Callek)
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-24 19:54 PST by Justin Wood (:Callek)
Modified: 2011-08-29 21:02 PDT (History)
0 users
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Justin Wood (:Callek) 2011-02-24 19:54:16 PST
STAGE_DIST is defined in both l10n.mk and browser/locales/Makefile.in twice.

We should remove the browser/locales/Makefile.in define to be sure these never get out of sync. They are currently in sync (except for style of the if)

http://mxr.mozilla.org/comm-central/source/mozilla/browser/locales/Makefile.in?mark=215-219#214

http://mxr.mozilla.org/mozilla-central/source/toolkit/locales/l10n.mk?mark=104-108#103
Comment 1 Justin Wood (:Callek) 2011-08-29 21:02:33 PDT
Looks like this was fixed in Bug 525438

Note You need to log in before you can comment on or make changes to this bug.