Closed Bug 636686 Opened 9 years ago Closed 9 years ago

Scrolling page is very slow and lagged on youtube

Categories

(Core :: Graphics, defect)

x86
Windows 7
defect
Not set

Tracking

()

VERIFIED WORKSFORME

People

(Reporter: alice0775, Unassigned)

References

()

Details

(Keywords: regression)

Build Identifier:
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b13pre) Gecko/20110224 Firefox/4.0b13pre ID:20110224030358

Play back youtube video,
Scrolling by mouse wheel and Up/Down key is very slow if video is visible in view port.
The scrolling become normal If video is outside of the view port.

Shockwave Flash
  File: NPSWF32.dll
  Version: 10.2.152.26
  Shockwave Flash 10.2 r152
Graphics
  Adapter Description: ATI Radeon HD 4300/4500 Series
  Vendor ID: 1002
  Device ID: 954f
  Adapter RAM: 512
  Adapter Drivers: aticfx64 aticfx64 aticfx32 aticfx32 atiumd64 atidxx64 atiumdag atidxx32 atiumdva atiumd6a atitmm64
  Driver Version: 8.821.0.0
  Driver Date: 1-26-2011
  Direct2D Enabled: true
  DirectWrite Enabled: true (6.1.7601.17514, font cache n/a)
  WebGL Renderer: Google Inc. -- ANGLE -- OpenGL ES 2.0 (ANGLE 0.0.0.541)
  GPU Accelerated Windows: 1/1 Direct3D 10


Reproducible: Always

Steps to Reproduce:
1. Start Minefield with new profile
2. Open ( Ex. http://www.youtube.com/watch?v=55s3T7VRQSc )
3. Scroll by mouse wheel and Page Up/Down key

Actual Results:
 Scrolling page is very slow

Expected Results:
 The scroll speed should be same as a page without the video.

First regression window:
Scrolling down is OK, Scrolling up is bad if the video is partially clipped. 
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=a6c18a123fbb&tochange=cf4d7946e2e0

Second regression window:
Scrolling by mouse wheel and Up/Down key is very slow if video is visible in view port.
And Video container is positioned slightly lagged.
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=d70a9ed2b89e&tochange=5b3d3d9fb9f3
Suspect:
933f8ff80777	Bas Schouten — Bug 587508: Workaround: Invalidate parts of the plugin area that might have content drawn to them. r=roc a=blocking-beta7
Are you sure about the first regression window? There was other stuff that landed the same day that I could expect to cause something like that.
(In reply to comment #1)
> Are you sure about the first regression window? There was other stuff that
> landed the same day that I could expect to cause something like that.
For testing first regrssion, you should _enable_ D2D etc.(used user.js as follows)

user_pref("dom.ipc.plugins.enabled", true);
user_pref("gfx.font_rendering.directwrite.enabled",true);
user_pref("mozilla.widget.render-mode", 6);
user_pref("gfx.direct2d.force-enabled", true);
user_pref("mozilla.widget.accelerated-layers", true);
user_pref("layers.accelerate-all", true);

In local build,
build from db88acba9e11 : bad scroll up speed .
I am experiencing the same problem but I've only noticed it in the last month. 
Happens on my desktop and laptop in safe mode or even a new profile.

Desktop:
  Graphics

        Adapter Description
        NVIDIA GeForce 8800 GTS 512

        Vendor ID
        10de

        Device ID
        0600

        Adapter RAM
        512

        Adapter Drivers
        nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um

        Driver Version
        8.17.12.6658

        Driver Date
        1-7-2011

        Direct2D Enabled
        true

        DirectWrite Enabled
        true (6.1.7601.17514, font cache 10.63 MB)

        WebGL Renderer
        Google Inc. -- ANGLE -- OpenGL ES 2.0 (ANGLE 0.0.0.541)

        GPU Accelerated Windows
        1/1 Direct3D 10
Scrolling is slightly faster with dom.ipc.plugins.enabled set to false but it's still not great.
If you really want to see how bad it is, try scrolling with the arrow keys with a video playing.  On my laptop with hardware acceleration and smooth scrolling enabled, it seriously takes at least a second to finish scrolling one line when pressing the up arrow key.  Scrolling is also pretty bad if you scroll while hovering any of the video links on the front page.  YouTube is pretty much the only site where I've noticed poor scrolling like this but considering the popularity of the site, I'm surprised this isn't blocking release.
I started experience  same problem with my 64bit 4.0 nighties some while ago. Don't remember exact day. I enjoyed how fast 4.0 performed page rendering. So it was a real bummer when one day youtube became very slow on my AMD Phenom II x6 with AMD Radeon 6870.This actually doesn't depend on hardware acceleration or page zoom. It scrolls slow in both modes.
No problem here with 2011-03-07 nightly, NVidia 9800GT, 258.96 driver.
Actually, although I don't have the slow scroll problem, I do seem to have the laggy problem i.e. extreme low gfx draw rate when scrolling with both hardware acceleration off and on, compared with scrolling in Chrome 9 with GPU accel off and optional GPU features enabled in about:flags, IE9 and Opera 11, voted.
Ah, goddamnit, tried it again & not sure now :( Maybe worth your trying earlier drivers to see if it makes a difference for you?
OK, absolutely sure now ;), it has massive stuttering/shaking whilst scrolling down or up if the video is showing, once scrolled past the video scrolling is smooth, this is with both hardware acceleration off or on.
Interestingly, on Opera 11.5/Chrome 9/Chromium/IE9 although they don't have the stuttering scroll bug, they have a worse bug in that the whole video freezes when scrolling (with latest stable flash).
I don't know who is responsible for this. But it seems that this bug has gone in latest nightly. Youtube now scrolls perfectly fast not matter is video actually on screen or not.
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:2.0b13pre) Gecko/20110322 Firefox/4.0b13pre
I think the problem was fixed by youtube as the greyscale text bug (bug 367142) is now also fixed in all browsers. Scrolling still lags the video on other browsers though, not a problem with Firefox though.
Confirmed, 
This problem was fixed by youtube.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → WORKSFORME
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.