@font-face rendering issues with Munro.ttf

RESOLVED INVALID

Status

()

Core
Layout: Text
RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: beta, Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: rdar://9058279, URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (X11; Linux i686; rv:2.0b12pre) Gecko/20110223 Firefox/4.0b12pre
Build Identifier: 

http://johndrinkwater.name/examples/webgl/minecraft/ uses a @font-face called Munro.ttf from http://www.tenbytwenty.com/munro.php

Os and os are rendered filled in on a Friends’ Mac Firefox/4.0b12pre, see URL for a screenshot.

Reproducible: Always
Component: General → Layout: Text
Product: Firefox → Core
QA Contact: general → layout.fonts-and-text
Version: unspecified → Trunk
I see the same thing if I just open that font in Font Book on Mac (or in the Finder preview for the TTF file).  In particular, the interiors of 'O', '0', and 'o' are filled in, as is the top circle in '8'.

Oh, and Safari on Mac renders the minecraft page above just like we do.  So does Chrome on MAc.

I do NOT see this behavior with gnome-font-viewer for the same exact file.

So this seems to be Mac-specific for some reason, but not specific to Firefox on Mac.
(In reply to comment #1)
> I see the same thing if I just open that font in Font Book on Mac (or in the
> Finder preview for the TTF file).  In particular, the interiors of 'O', '0',
> and 'o' are filled in, as is the top circle in '8'.
> 
> Oh, and Safari on Mac renders the minecraft page above just like we do.  So
> does Chrome on MAc.
> 
> I do NOT see this behavior with gnome-font-viewer for the same exact file.
> 
> So this seems to be Mac-specific for some reason, but not specific to Firefox
> on Mac.

Indeed; it looks like a bug in the Apple TrueType rasterizer. Closing this as "invalid", as it's not a mozilla bug, but filed rdar://9058279 to report this to Apple.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
Whiteboard: rdar://9058279
OS: Linux → Mac OS X
You need to log in before you can comment on or make changes to this bug.