Email Header deletes instead of Loads when Email has been placed in Trash Folder

RESOLVED DUPLICATE of bug 629547

Status

RESOLVED DUPLICATE of bug 629547
8 years ago
8 years ago

People

(Reporter: dcparsons, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US) AppleWebKit/534.13 (KHTML, like Gecko) Chrome/9.0.597.98 Safari/534.13
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.13) Gecko/20101207 Lightning/1.0b2 Thunderbird/3.1.7

Config: 6 POP accounts, global inbox, download headers only on GetMail - no autofetch.
Problem: 
Scenario 1: When using Fetch / List headers only with Global Inbox, and the email has been moved to the trash folder without downloading.  Before emptying trash if you click on the "Click here to download the rest of the message" hyperlink displayed in the body area, the message does download, but dissappears - it is not in the trash folder, drafts, inbox etc.  It seems to download and then delete itself.
Scenario 2: When using Fetch / List headers only with Global Inbox, and the email has been moved to the trash folder without downloading - THEN moved back to the Global Inbox BEFORE any Fetch etc operation has been launched.  Again if you click on the "Click here to download the rest of the message" hyperlink displayed in the body area, the message does download, but then dissappears immediately - it is not in the trash folder, drafts, inbox etc.  It seems to download and then delete itself.
Conclusion: Somehow the placement of the email header originally in the trash box, regardless of whether it is moved out again, triggers a delete step even though a delete step (or empty trash step) has NOT occurred.

** This problem occurred in previous versions of Tbird, but I didn't figure out how to reproduce it easily.  I would dump the email headers by emptying trash having already moved back the header I wanted to "undeleted" by moving back to Inbox.  Then when I got around to downloading it - the trash folder was already empty so I didn't make the connection when the now Inbox message simply dissappeared.

Reproducible: Always

Steps to Reproduce:
1.Config with multiple pop hosts and Global Inbox config using download headers only, not autofetch.
2.Leave some headers in inbox, move some to trash.
3. Click on download header while the email is in trash. It will disappear.
4. Move another header only from trash back to Inbox, and then click (in Inbox) on the download email link of the moved back header.  It will disappear also.
Actual Results:  
Email header / body / everything simply disappears.


The email should not have been deleted.  An email is not deleted until it is in the Trash Folder and you push Empty Trash.

I have not been able to figure out a work-around.
Anything in Tools -> Error console when this happens ?
Component: Folder and Message Lists → Networking: POP
Product: Thunderbird → MailNews Core
QA Contact: folders-message-lists → networking.pop

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 629547
You need to log in before you can comment on or make changes to this bug.