Some Flash animations can receive focus with the tab key (without clicking inside)

RESOLVED INVALID

Status

()

Firefox
General
--
major
RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: Sebastien Delorme, Unassigned)

Tracking

({flashplayer})

Trunk
flashplayer
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0b11) Gecko/20100101 Firefox/4.0b11
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b11) Gecko/20100101 Firefox/4.0b11

Some Flash animations can receive focus with the tab key (without clicking inside).

So :
- it's impossible to exit when the focus is in Flash animation 
- it's impossible to reach HTML links after Flash animation

Other examples :
- http://www.ter-sncf.com/ (France Map and advertisements)
- http://www.spie-job.com/ (World Map and video player)

But these Flash animations can still not receive focus without mouse click inside :
- http://www.youtube.com/watch?v=l6g5hoBYlf0&feature=topvideos


Reproducible: Always

Steps to Reproduce:
1. Go on the page ;
2. Use the tab key until the video player ;
3. When focus is on Flash animation, it is impossible to exit or to reach next HTML links.
Actual Results:  
Flash video player can receive focus with the tab key (without clicking inside).
Next HTML links can't receive focus with the tab key.

Expected Results:  
On FF 3.6 and less, Flash animations could not receive without mouse click in it.

But the ideal would be to continue the tabulation on the HTML elements located after Flash animation.
(Reporter)

Updated

7 years ago
Keywords: flashplayer
I think this might infringe the Eolas patent.

Also I think this is due to Bug 554635.
Making this bug confidential because of the possible patent infringement issue.
I can provide a simple fix to be sure we don't focus a plugin with the TAB key. Is that the only thing this patent is about? I mean, using .focus() should still work, right?
Group: mozilla-corporation-confidential
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: x86 → All
Version: unspecified → Trunk

Comment 3

7 years ago
The current behavior might be intentional (we're working on making it possible to tab out of plugins, so it makes perfect sense that you'd be able to tab into them). I don't know anything about the patent implications.
(Reporter)

Comment 4

7 years ago
(In reply to comment #3)
> The current behavior might be intentional (we're working on making it possible
> to tab out of plugins, so it makes perfect sense that you'd be able to tab into
> them). I don't know anything about the patent implications.

Yes it makes perfect sense to be able to tab into plugins (it could be a very good point for accessibility). But as it's impossible to tab out for now, it's problematic.
Can anyone comment about the possible patent implications?

Comment 6

7 years ago
We have no comment other than that this bug does not need to be fixed.
Group: mozilla-corporation-confidential
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
I'm gonna reopen that for the first issue (can't leave some Flash animations). Unless this is a dupe.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---

Comment 8

7 years ago
That's bug 93149 and 78414.
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.