Default width for common dialogs is too big

VERIFIED FIXED

Status

SeaMonkey
UI Design
VERIFIED FIXED
17 years ago
10 years ago

People

(Reporter: Blake Ross, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Assignee)

Description

17 years ago
Many dialogs are far too wide for their content.  Ideally the dialog would size 
to fit the text, but sizeToContent isn't working right (at the moment, at 
least).  Attaching a patch to decrease the width to a more reasonable one, and 
make it a minimium width.  It also increases the minimum height nominally (to 
match Windows more closely).
(Assignee)

Comment 1

17 years ago
Created attachment 21258 [details] [diff] [review]
[patch] use minimum width and make it more reasonable
(Assignee)

Comment 2

17 years ago
cc'ing alec for sr
Status: NEW → ASSIGNED

Comment 3

17 years ago
r=timeless.
cc german/mpt in case they want to object.
Keywords: approval, patch
OS: Windows ME → All
Hardware: PC → All

Comment 4

17 years ago
Mac OS has a standard width and minimum height for alerts -- and since Mozilla
is (incorrectly) using dialogs for alerts at the moment, we should at least use
the right measurements to make things a little bit nicer. Unfortunately I don't
have access to a Mac at the moment, so I can't report what these measurements are.

Can someone who is on a Mac please:
* bring up a standard Mac OS alert, e.g. by trying to rename a file, giving it
  the same name as a file which is already in that folder;
* take a snapshot of that dialog (Caps Lock, Command+Shift+4);
* open the snapshot, and measure the width and height in pixels, reporting the
  results in this bug.
(Assignee)

Comment 5

17 years ago
Created attachment 21290 [details] [diff] [review]
[patch] workaround bug 51698, add more space between textfields and buttons

Comment 6

17 years ago
mpt: setting alerts to an absolute width would make sense for the classic 
theme, as only there can we predict what font is being used. All other themes 
should be able to autosize as needed.
(Assignee)

Comment 7

17 years ago
System fonts are used in Classic.  Also, this can't really be theme-dependent.

Comment 8

17 years ago
German: No, we divide the width by 12 (the system font size), and that gives us 
the appropriate width no matter which font is used: 31 ems.
Netscape nav triage team: as per Alec Flett's pre-triage recommendation, this 
bug is nsbeta1-.
Keywords: nsbeta1-
(Assignee)

Comment 10

17 years ago
So, what do we want to do with this one?

Comment 11

17 years ago
This is a dupe of bug 31319 or the other way round, would someone mark it as 
such?
yeah, sounds like it... [but others correct me if it really isn't a dup.]

*** This bug has been marked as a duplicate of 31319 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 13

17 years ago
I would rather mark this the other way, because this bug has the patches, 
relevant discussion, review, and appropriate people cc'ed...
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Assignee)

Comment 14

17 years ago
*** Bug 31319 has been marked as a duplicate of this bug. ***

Comment 15

17 years ago
modern uses system fonts too now
(Assignee)

Comment 17

17 years ago
checked in.
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED
tested this w/an alert dialog containing a textfield. eg, using an htaccess
dialog or the mailnews login dialog [used the latter this time --the OK button
is in focus, and outlined in black]. vrfy fixed on linux, winnt and mac:
2001.02.09.08 comm bits.
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite

Updated

10 years ago
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.