Form helper buttons jump to the middle of the right-side screen when panning up and down the page

RESOLVED WORKSFORME

Status

Firefox for Android Graveyard
General
P3
normal
RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: aakashd, Unassigned)

Tracking

Trunk
ARM
Android

Details

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
Build Id:
Mozilla/5.0 (Android; Linux armv71; rv:2.0b12pre) Gecko/20110225 Firefox/4.0b13pre Fennec/4.0b6pre

Steps to Reproduce:
1. Login into gmail.com
2. Pan to the bottom of the page
3. Tap on the search field
4. Pan to the top of the page
5. Pan back to the bottom of the page

Actual Results:
The form helper buttons will be on the right-center part of the screen.

Expected Results:
The form helper buttons should be on the bottom-right part of the screen.
(Reporter)

Updated

7 years ago
OS: All → Android
Hardware: All → ARM
(Reporter)

Comment 1

7 years ago
Created attachment 515640 [details]
bug screenshot
not a blocker, but would take a low-risk fix
tracking-fennec: ? → 2.0-
Created attachment 515973 [details]
Buttons scroll up and cover input field
I just saw this on our support page. This is confusing, especially as the form helper buttons can cover the input field:

(1) from Fennec Start page (about:home) click on "Get Help"
(2) Scroll down, tap into the search field -> the form assistant arrows appear
(3) scroll the page up slightly

Result: form assistant buttons scroll up, covering parts of the input field
Expected: form assistant buttons don't scroll up and never cover the input field.
Now that I'm looking again at your screenshots I wonder if this bug could be related to the bug I've fixed this morning (should be in tomorrow nightly for you or I know Aakash use a devel tree sometimes :) ). 

Could you please check if you can reproduce with bug 637912 checked-in?
It sounds like Thomas is seeing this again :(

I would like a steps to reproduce that make it happen for me!
Thomas or Aakash, do you still see that?
works for me now. Aakash: can you check?
(Reporter)

Comment 9

7 years ago
This works for me now on build:
Mozilla/5.0 (Android; Linux armv7l; rv:2.2a1pre) Gecko/20110412 Firefox/4.2a1pre Fennec/4.1a1pre ID:20110412042231
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.