[Mac] Combination of running two sites crashes my video driver

RESOLVED DUPLICATE of bug 622836

Status

()

Core
Graphics
RESOLVED DUPLICATE of bug 622836
7 years ago
7 years ago

People

(Reporter: marcia, Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [4b12])

Seen while running Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b12) Gecko/20100101 Firefox/4.0b12.

STR:

1. Load http://www.lewpen.com/articles/3d-graphics/webgl/realtime-raytracer/raytracer-008-bumpy-textures/ and http://mrdoob.github.com/three.js/examples/materials_cars.html in another tab.
2. Eventually the combination of both sites running causes the video driver on my Mac to crash, and I have to reboot my entire machine.
3. Sometimes it takes some time for it to happen, but I quite a bit of beachballing before it happens.

Adapter Description
0x22600,0x22600,0x20400
Vendor ID
0000
Device ID
0000
Adapter RAM

Adapter Drivers

Driver Version

Driver Date

Direct2D Enabled
false
DirectWrite Enabled
false
WebGL Renderer
NVIDIA Corporation -- NVIDIA GeForce 9600M GT OpenGL Engine -- 2.1 NVIDIA-1.6.26
GPU Accelerated Windows
1/1 OpenGL
blocking2.0: --- → ?
Yeah, this is the saddest OpenGL/Mac story. Just the raytracer demo is enough to crash the system. As far as I know it happens also on 10.6 so it won't even get fixed by the 10.5 blacklisting (bug 636611). We don't have a good solution to offer here. Blacklisting WebGL on 10.6 would be really sad. If we knew precisely what in this shader was killing the Mac OpenGL implementation, we could handle it in ANGLE, but we don't know that.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 622836
I am interested in your Mac OS X version number.
10.6.7

(In reply to comment #2)
> I am interested in your Mac OS X version number.
blocking2.0: ? → ---
You need to log in before you can comment on or make changes to this bug.