If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Crash in tinyMCE editor (tried to delete empty table)

RESOLVED DUPLICATE of bug 636117

Status

()

Core
Editor
--
critical
RESOLVED DUPLICATE of bug 636117
7 years ago
7 years ago

People

(Reporter: Alexander Gerasimov, Unassigned)

Tracking

Trunk
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b12pre) Gecko/20110222 Firefox/4.0b12pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b12pre) Gecko/20110222 Firefox/4.0b12pre

Crashed in tinyMCE editor when tried to delete empty table. Document was imported from MS Word 2010.

Reproducible: Couldn't Reproduce

Steps to Reproduce:
1. Paste document from MS Word with table to <textarea> with tinyMCE editor;
2. Delete all rows in it;
3. Try to delete the table;
Actual Results:  
Firefox crashes

Expected Results:  
Firefox should not crash

Crash Report [@ nsCOMArray_base::InsertObjectsAt(nsCOMArray_base const&, int) ] 

https://crash-stats.mozilla.com/report/index/bp-1235f317-ebac-405c-ad84-df8382110225
(Reporter)

Comment 1

7 years ago
https://crash-stats.mozilla.com/report/index/bp-f7f13f2d-35dc-4c89-a1d0-d3e0e2110225
Now reproduced with right-clicking on empty table. This could be related to Bug 636117
(Reporter)

Updated

7 years ago
Version: unspecified → Trunk
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 636117

Comment 3

7 years ago
(In reply to comment #0)
> Steps to Reproduce:
> 1. Paste document from MS Word with table to <textarea> with tinyMCE editor;
> 2. Delete all rows in it;
> 3. Try to delete the table;

Alexander, can you reproduce this reliably?  If yes, can you please record the HTML contents of the TinyMCE instance by clicking the "HTML" button in TinyMCE and copying all of the code, and attaching it to the bug?  Also, which version of TinyMCE are you using?

I can probably fix this if I can reproduce the crash.

Updated

7 years ago
Component: General → Editor
Product: Firefox → Core
QA Contact: general → editor
You need to log in before you can comment on or make changes to this bug.