Navigating to the full site is not always successful

VERIFIED FIXED in 5.12.12

Status

VERIFIED FIXED
8 years ago
3 years ago

People

(Reporter: krupa.mozbugs, Assigned: oremj)

Tracking

5.12.12

Details

(Whiteboard: [mamo][post-freeze+])

(Reporter)

Description

8 years ago
Fennec 4.0b2 on Droid Incredible(htc)

steps to reproduce:
1. Load the mobile homepage
2. Click on "View Full site" button in the footer

expected behavior:
User navigates to the full site


observed behavior:
mobile AMO reloads. However, doing a search after step#2, loads the full site.

Comment 1

8 years ago
do you know if it works in the latest beta? (we're on b5 now!)
If it's using cookies it should work in any browser
(Reporter)

Comment 3

8 years ago
reproducible in 4.0b5 as well
I'd like to get these pages out next thursday, so leaving this in .12.  Let me know if I can help with anything here.
Assignee: nobody → jbalogh
Whiteboard: [mamo] → [mamo][post-freeze+]
oremj: Please update the mobile trafficscript from bug 626871 to Vary on User-Agent, Cookie. That's the only problem I can imagine having here. The View Full Site button worked fine for me and set the cookie properly.

-  http.addResponseHeader("Vary", "User-Agent");
+  http.addResponseHeader("Vary", "User-Agent,Cookie");
Assignee: jbalogh → jeremy.orem+bugs
(Assignee)

Comment 6

8 years ago
I've made this change. Also, it looks like we haven't enabled this in production yet. Should it be enabled?
(In reply to comment #6)
> I've made this change. Also, it looks like we haven't enabled this in
> production yet. Should it be enabled?

Not until thursday.  Krupa - can you verify if this if fixed?
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Reporter)

Comment 8

8 years ago
works now. Marking this verified.
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.