Startup crash [@ InitDwriteBG ] in virtual environments

RESOLVED FIXED

Status

()

Core
Graphics
--
critical
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: Scoobidiver (away), Assigned: jfkthame)

Tracking

({crash, regression})

Trunk
x86
Windows 7
crash, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
It is a new crash signature in the trunk.
It seems to be related to virtual environments.
It is #1000 crasher in 4.0b11 on Windows.

Signature	InitDwriteBG
UUID	1cbd00b3-ecbe-4870-a4df-4db6f2110225
Time 	2011-02-25 22:44:19.673836
Uptime	0
Install Age	0 seconds since version was first installed.
Product	Firefox
Version	4.0b13pre
Build ID	20110225030201
Branch	2.0
OS	Windows NT
OS Version	6.1.7601 Service Pack 1
CPU	amd64
CPU Info	family 6 model 23 stepping 10
Crash Reason	EXCEPTION_ACCESS_VIOLATION_READ
Crash Address	0x0
Processor Notes 	WARNING: Json file missing Add-ons

Frame 	Module 	Signature [Expand] 	Source
0 	xul.dll 	InitDwriteBG 	toolkit/xre/nsAppRunner.cpp:2776
1 	kernel32.dll 	kernel32.dll@0x1652c 	
2 	ntdll.dll 	ntdll.dll@0x2c520 	
3 	kernel32.dll 	kernel32.dll@0x9932f 	
4 	kernel32.dll 	kernel32.dll@0x9932f 	

More reports at:
https://crash-stats.mozilla.com/report/list?product=Firefox&range_value=4&range_unit=weeks&signature=InitDwriteBG
(Assignee)

Comment 1

7 years ago
Created attachment 515327 [details] [diff] [review]
patch - check windows API calls for failure

If either LoadLibraryW() or DWriteCreateFactory() fails in the background thread for any reason, it looks like we'd crash here. Best to always check results of system API calls.
Assignee: nobody → jfkthame
Attachment #515327 - Flags: review?(jdaggett)
(Assignee)

Updated

7 years ago
Blocks: 602792
(Assignee)

Updated

7 years ago
Attachment #515327 - Attachment description: patch (untested) - check windows API calls for failure → patch - check windows API calls for failure

Updated

7 years ago
Attachment #515327 - Flags: review?(jdaggett) → review+
(Assignee)

Comment 2

7 years ago
Comment on attachment 515327 [details] [diff] [review]
patch - check windows API calls for failure

Requesting approval-2.0: this adds error checking to the result of a couple of Windows API calls. This carries essentially no risk, and protects us from crashing in the event that the calls here fail for some reason.
Attachment #515327 - Flags: approval2.0?
Attachment #515327 - Flags: approval2.0? → approval2.0+
(Assignee)

Comment 3

7 years ago
Pushed http://hg.mozilla.org/mozilla-central/rev/f7de2d113096 - this should prevent the potential crashes here. Please re-open if it keeps happening.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Crash Signature: [@ InitDwriteBG ]
You need to log in before you can comment on or make changes to this bug.