Newer NetBSD version have IPv6 support - Mozilla doesn't know about this

RESOLVED FIXED in 4.2

Status

enhancement
P3
normal
RESOLVED FIXED
19 years ago
19 years ago

People

(Reporter: martin, Assigned: wtc)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

When building on NetBSD 1.5 or newer, we always have userland (i.e. library)
support for IPv6 available. With custom kernels, kernel support may be missing,
so we must check for its presence at runtime.

The suggested fix adds the appropriate defines to the NetBSD configuration
files. I have no idea wheter we need the USE_IPV6 make variable (used by
nsprpub/config/config.mk and set only by AIX.mk); it seems to work without.
Posted patch suggested fixSplinter Review
It is not necessary to set the USE_IPV6 make variable.
Your testing of the __NetBSD_Version__ macro in _netbsd.h
is equivalent to what AIX.mk and config.mk do: to define
_PR_INET6 for certain versions of the operating system.
In fact, your patch is almost identical to what we do in
_linux.h, except that there we check the glibc version.
I guess the issue is the same: user library supports the
IPv6 socket API, but the kernel may not have the IPv6 stack.

I checked in the patch on the main trunk.
/cvsroot/mozilla/nsprpub/pr/include/md/_netbsd.h, revision 3.13

Also checked it in on the NSPRPUB_CLIENT_BRANCH.
/cvsroot/mozilla/nsprpub/pr/include/md/_netbsd.h, revision 3.7.20.4
Severity: normal → enhancement
Status: NEW → RESOLVED
Closed: 19 years ago
Priority: -- → P3
Resolution: --- → FIXED
Target Milestone: --- → 4.2
You need to log in before you can comment on or make changes to this bug.