Last Comment Bug 637018 - White line above content in glass w/maximized window, navigation bar and favorites bar disabled
: White line above content in glass w/maximized window, navigation bar and favo...
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Theme (show other bugs)
: Trunk
: All Windows 7
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
data:text/html,<body bgcolor="black">
Depends on: 633282
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-26 07:44 PST by Peter Henkel [:Terepin]
Modified: 2012-06-09 02:21 PDT (History)
9 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Maximized - not correct (13.88 KB, image/jpeg)
2011-02-28 06:20 PST, Peter Henkel [:Terepin]
no flags Details
Unmaximized - correct (15.04 KB, image/jpeg)
2011-02-28 06:21 PST, Peter Henkel [:Terepin]
no flags Details

Description Peter Henkel [:Terepin] 2011-02-26 07:44:32 PST
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b13pre) Gecko/20110226 Firefox/4.0b13pre
Build Identifier: 

It's hard for me to describe what exactly is happening, although I'm sure it was happening before. It occurs either after landing new Aero border calculating or after after baking it out. Jimm will know more.

Reproducible: Always
Comment 1 Peter Henkel [:Terepin] 2011-02-28 06:20:33 PST
Created attachment 515599 [details]
Maximized - not correct
Comment 2 Peter Henkel [:Terepin] 2011-02-28 06:21:42 PST
Created attachment 515600 [details]
Unmaximized - correct

Upps, I forgot to attach screenshots. My bad.
Comment 3 Wes Kocher (:KWierso) 2011-02-28 13:04:05 PST
Isn't this just  bug 572160?
Comment 4 Peter Henkel [:Terepin] 2011-02-28 13:45:35 PST
Nope, the issue here is that white line in page's content area.
Comment 5 imradyurrad 2011-02-28 15:38:00 PST
(In reply to comment #4)
> Nope, the issue here is that white line in page's content area.

Change the title then.
Comment 6 [not reading bugmail] 2011-02-28 17:02:33 PST
I thought that was fixed by a backout bug once already.
Comment 7 Jim Mathies [:jimm] 2011-02-28 17:42:05 PST
(In reply to comment #6)
> I thought that was fixed by a backout bug once already.

That was a different problem that was fixed by a back out. This has something to do with all the toolbars being disabled.
Comment 8 Jim Mathies [:jimm] 2011-02-28 17:46:15 PST
Looks like it may be tied to the tabs in titlebar changes. A regression range would help.
Comment 9 Eddward 2011-03-01 00:54:47 PST
Looks fine here: http://img18.imageshack.us/img18/5592/59235467.jpg
Comment 10 Peter Henkel [:Terepin] 2011-03-03 08:35:26 PST
(In reply to comment #8)
> Looks like it may be tied to the tabs in titlebar changes. A regression range
> would help.

I would love to help you, but these issue was introduced with either new border calculation, or after backing it out. Unfortunately I wasn't aware of this bugs so I have no idea where to look.
Comment 11 :Felipe Gomes (needinfo me!) 2011-03-11 14:05:38 PST
Not a widget bug, just a theme oddity. That line is this element: http://hg.mozilla.org/mozilla-central/annotate/e633e7a4af4b/browser/themes/winstripe/browser/browser.css#l75

For some reason it ends up positioned 1px lower on a maximized window, maybe on purpose?
Comment 12 Wes Kocher (:KWierso) 2011-03-11 14:12:39 PST
(In reply to comment #11)
> For some reason it ends up positioned 1px lower on a maximized window, maybe on
> purpose?

Random uneducated guess: There's a gap between the top edge of the tabs and the edge of the window when the tabs are up in the titlebar when the window is maximized, maybe that's pushing that element down too far?
Comment 13 Jim Mathies [:jimm] 2011-05-13 10:00:56 PDT
This should be fixed in nightlies starting tomorrow. Although in testing be wary of bug 656946.
Comment 14 Peter Henkel [:Terepin] 2011-08-04 11:47:18 PDT
Jim, can you mark this as RESOLVED FIXED? It was fixed some time ago (in UX branch at least).

Note You need to log in before you can comment on or make changes to this bug.