Closed Bug 637032 Opened 9 years ago Closed 9 years ago

Repeated Console messages in the Web Console not showing number

Categories

(DevTools :: General, defect)

defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: rcampbell, Assigned: rcampbell)

References

Details

Attachments

(1 file)

in today's nightly, 2011-02-26, repeated console messages are not showing the numeric badge next to the item.

To reproduce:
1. Open a web console.
2. In the input line, enter:
for (let i = 0; i < 10; i++) console.log("hi");
3. Hit the enter key

You'll see:
[13:32:08.745] for (let i = 0; i < 10; i++) console.log("hi");
[13:32:08.753] "hi"
[13:32:08.767] undefined

You should see
[13:32:08.745] for (let i = 0; i < 10; i++) console.log("hi");
[13:32:08.753] "hi" (10)
[13:32:08.767] undefined
Assignee: nobody → rcampbell
Status: NEW → ASSIGNED
Wondered why this didn't show up in the unittests and discovered that I'd lost the addition to the makefile along the way. Re-added and fixed the console filtering.
Attachment #515360 - Flags: review?(gavin.sharp)
Comment on attachment 515360 [details] [diff] [review]
[checked-in] repeated-console

While I'm not comfortable reviewing this patch, it gets my stamp of pre-approval should someone convince Gavin to look at the one-liner. Looks safe to me!
Comment on attachment 515360 [details] [diff] [review]
[checked-in] repeated-console

r=sdwilsh
Attachment #515360 - Flags: review?(gavin.sharp) → review+
Duplicate of this bug: 637602
Comment on attachment 515360 [details] [diff] [review]
[checked-in] repeated-console

http://hg.mozilla.org/mozilla-central/rev/9f426a5d89f5
Attachment #515360 - Attachment description: repeated-console → [checked-in] repeated-console
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Verified
Status: RESOLVED → VERIFIED
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.