If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Settings for html5 video and audio content

RESOLVED INVALID

Status

()

Firefox
Preferences
RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: kolAflash, Unassigned)

Tracking

Trunk
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; de; rv:1.9.2.13) Gecko/20101203 SUSE/3.6.13-0.2.1 Firefox/3.6.13
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; de; rv:1.9.2.13) Gecko/20101203 SUSE/3.6.13-0.2.1 Firefox/3.6.13

Hi,
it looks like there's any possibility to adjusting settings for playback of html5 audio and video content.

For exmaple, to tell Firefox to use a certain audiodevice, or maybe PulseAudio on Linux, for the audio output. Or in which Firefox renders html5 videos (Hardware Acceleration, OpenGL, X11-Videorendering, XV-Videorendering).

This already caused me some problems when changing my Linux to pulse audio.
And now I'm experiencing heavy performance problems on video pages of the german news website www.tagesschau.de.
For example at this video:
http://www.tagesschau.de/multimedia/video/ondemand100_id-video866726.html
I'd like to try some videosettings. But there seems to be no possibility to adjust those settings.
For the certain problems of www.tagesschau.de -> Those only seem to appear on Linux (more exactly openSUSE 11.3 using an Ati video card). I tried it on a computer and a notebook (both having Ati cards).
On Windows everything works fine, having a good video performance. I didn't test it using other linux distributions.

Could you add some way to change video settings? Maybe using the about:config page?

Thanks
colAflash

Reproducible: Always

Updated

7 years ago
Version: unspecified → Trunk
>Could you add some way to change video settings?
Not needed because there no other options available for audio.
bug 503691i is marked as wontfix.

The following is only valid for Gecko2.0 here and not Gecko1.9.2 (FF3.6.x):
The whole browser uses the same hardware acceleration, not only html5 videos.
but unfortunately hardware acceleration on linux sucks, see https://hacks.mozilla.org/2011/01/firefox-4-beta-9-a-huge-pile-of-awesome/comment-page-1/#comment-
You can see the state of the hardware acceleration in about:support and there are already options in abOUt:config.

I will mark this invalid. No other audio backend is supported and hardware acceleration on linux and ati cards are blacklisted
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.