Multiple instances of FF4 B12 w/ different profiles have their task bar icons collapsed in Win7

RESOLVED DUPLICATE of bug 577867

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 577867
7 years ago
7 years ago

People

(Reporter: Pascal, Unassigned)

Tracking

Trunk
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b12) Gecko/20100101 Firefox/4.0b12
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b12) Gecko/20100101 Firefox/4.0b12

My girlfriend and I use the same computer. In FF3, I had two separate shortcuts on the Windows 7 taskbar, each launching a separate instance of FF using a different profile so we could remain signed in to our various sites. With FF3 this worked fine; all of my windows would stack under my task bar icon, and all of her windows would stack under her task bar icon.

With FF4, all open Firefox windows are stacked under the same task bar icon. The actual windows are still running under different profiles. All of our separate sessions and preferences are maintained. Its just something about how FF is presenting itself to Win7 that causes Win7 to mistakenly believe that these windows all belong to the same Firefox instance.

Reproducible: Always

Steps to Reproduce:
1. Create two profiles in the Firefox Profile manager
2. Create two shortcuts to firefox.exe, and pin them both to the Win7 task bar
3. For the first shortcut, add the command line arguments '-P "Profile1"'
4. For the second shortcut, add the command line arguments '-P "Profile2" -no-remote'  (no-remote so links clicked elsewhere in the OS aren't handled by this instance).
5. Open one instance of each shortcut.
Actual Results:  
Both windows will stack behind the task-bar icon of the first shortcut (the one without no-remote)

Expected Results:  
Windows remain separated under the task-bar icons they were launched from

I'm running Windows 7 Professional 64bit, but using FF4 32bit.

Updated

7 years ago
Version: unspecified → Trunk

Comment 1

7 years ago
Reproduceable on:
Mozilla/5.0 (Windows NT 6.1; rv:2.0b12) Gecko/20100101 Firefox/4.0b12

*Note: I would vote it more as an enhancement than as a bug.
(Reporter)

Comment 2

7 years ago
Using RC1 - Now Firefox actively DELETES one of my taskbar icons. This is getting ridiculous. Raising severity.
Severity: minor → normal

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 577867
You need to log in before you can comment on or make changes to this bug.