newuser do not accept . (dot) in the password

UNCONFIRMED
Unassigned

Status

Webtools
Mozbot
UNCONFIRMED
7 years ago
7 years ago

People

(Reporter: Anderson Kaiser, Unassigned)

Tracking

Trunk
x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.13) Gecko/20101206 Red Hat/3.6.13-2.el6_0 Firefox/3.6.13
Build Identifier: Mozbot 2.6

When I use the newuser option after auth process the mozbot do not accept a '.' (dot) in the password field.

Reproducible: Always

Steps to Reproduce:
1. Uncompress the mozbot.version.tar.gz file and run the mozbot.pl script
2. Insert all the informations like IRC server, port, email and so on.
3. Join the same irc channel that the Bot and login as admin in the bot (in my case the bot's name is bottest)

<bottest> Hi admin
<Kaiser> newuser test ab.12345 ab.12345
<bottest> Sorry, I've no idea what 'newuser test ab.12345 ab.12345' might be.
<Kaiser> newuser Kaiser password password
<bottest> New user 'Kaiser' added with password 'password' and no rights.
<Kaiser> changepassword Kaiser abc123 abc123
<bottest> Password changed for user 'Kaiser'.
<Kaiser> changepassword Kaiser ab.12345 ab.12345
<bottest> Sorry, I've no idea what 'changepassword Kaiser ab.12345 ab.12345' might be.

Actual Results:  
The bot do not accept the . character in the password field.

Expected Results:  
Be able to use strong passwords when create users to administrate the bot.
You need to log in before you can comment on or make changes to this bug.