Firefox 4.0b12 Crash Report [@ nsAString_internal::Assign(unsigned short const*, unsigned int) ]

RESOLVED WONTFIX

Status

()

--
critical
RESOLVED WONTFIX
8 years ago
8 years ago

People

(Reporter: mdykun, Unassigned)

Tracking

({crash, crashreportid})

Trunk
x86
All
crash, crashreportid
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b12) Gecko/20100101 Firefox/4.0b12
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0b12) Gecko/20100101 Firefox/4.0b12

Crashing when I try to open testcase of Bug 620492

Reproducible: Always

Steps to Reproduce:
1. Open attachment in Bug 620492 https://bugzilla.mozilla.org/attachment.cgi?id=499125

Actual Results:  
Crash


crashreport here:https://crash-stats.mozilla.com/report/index/bp-40f6f600-fab1-4a91-bad5-4d94d2110227

Comment 1

8 years ago
Does the issue still occur if you start Firefox in Safe Mode? http://support.mozilla.com/en-US/kb/Safe+Mode

How about with a new, empty profile? http://support.mozilla.com/en-US/kb/Basic+Troubleshooting#Make_a_new_profile

Does the issue occur with the latest nightly? http://nightly.mozilla.org/

I get a DOS but not a crash with Mozilla/5.0 (Windows NT 5.1; rv:2.0b13pre) Gecko/20110226 Firefox/4.0b13pre ID:20110226030401
Keywords: crash, crashreportid
Version: unspecified → Trunk

Comment 2

8 years ago
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b13pre) Gecko/20110227 Firefox/4.0b13pre

I can reproduce.

[@ mozalloc_abort(char const* const) | mozalloc_handle_oom() | nsTArray_base<nsTArrayDefaultAllocator>::EnsureCapacity(unsigned int, unsigned int) | guard32.dll@0x7 ] 
bp-0050917d-e020-4d45-bf9a-9e8372110227

Comment 3

8 years ago
Reproducible on :
Mozilla/5.0 (Windows NT 5.1; rv:2.0b13pre) Gecko/20110227 Firefox/4.0b13pre

Crash report:
http://crash-stats.mozilla.com/report/index/bp-e773bfe0-f1d1-4ad1-91a6-455cb2110228
Able to reproduce on Build identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b13pre) Gecko/20110227 Firefox/4.0b13pre

Crash Report:
http://crash-stats.mozilla.com/report/index/bp-249b2bd2-09a3-4ee9-969a-41a072110228
http://crash-stats.mozilla.com/report/index/bp-93953e10-8421-466c-8738-84c572110228
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows NT → All
Seems to be an OOM Crash. Does that happen on today's Nightly, too?
Component: General → General
Product: Firefox → Core
QA Contact: general → general

Comment 6

8 years ago
Given that bug 620492 is about a DoS from appending a string to itself over and over, I am unsurprised.  In my opinion, this is a WONTFIX, since we're OOMing correctly.  Any work to avoid this should probably happen in the original bug.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

8 years ago
Crash Signature: [@ nsAString_internal::Assign(unsigned short const*, unsigned int) ]
You need to log in before you can comment on or make changes to this bug.