Crash with Google App Engine plugin [@ xpGwtDevPlugin.dll@0x4ffd ]

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
8 years ago
7 years ago

People

(Reporter: scoobidiver, Unassigned)

Tracking

({crash, regression})

Trunk
x86
Windows 7
crash, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

8 years ago
It is a new crash signature that first appeared in 4.0b12pre/20110215.
It is currently #48 top crasher in 4.0b12.

Signature	xpGwtDevPlugin.dll@0x4ffd
UUID	4cbbed34-a359-43aa-824e-3c58c2110228
Time 	2011-02-28 04:38:19.693215
Uptime	58
Last Crash	113 seconds before submission
Install Age	319 seconds (5.3 minutes) since version was first installed.
Product	Firefox
Version	4.0b12
Build ID	20110222210221
Branch	2.0
OS	Windows NT
OS Version	6.1.7601 Service Pack 1
CPU	x86
CPU Info	AuthenticAMD family 16 model 4 stepping 2
Crash Reason	EXCEPTION_ACCESS_VIOLATION_READ
Crash Address	0x4
User Comments	Exception in thread "Code server for kidsweb from Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b12) Gecko/20100101 Firefox/4.0b12 on http://127.0.0.1:8888/KidsWeb.html?gwt.codesvr=127.0.0.1:9997 @ 4pv3})AWl[ZkFyo@" com.google.gwt.dev.shell.BrowserChannel$RemoteDeathError: Remote connection lost at com.google.gwt.dev.shell.BrowserChannelServer.processConnection(BrowserChannelServer.java:521) at com.google.gwt.dev.shell.BrowserChannelServer.run(BrowserChannelServer.java:352)
App Notes 	AdapterVendorID: 1002, AdapterDeviceID: 9490, AdapterDriverVersion: 8.821.0.0

Frame 	Module 	Signature [Expand] 	Source
0 	xpGwtDevPlugin.dll 	xpGwtDevPlugin.dll@0x4ffd 	
1 	mozjs.dll 	JSObject::allocSlot 	js/src/jsobj.cpp:4409
2 	xpGwtDevPlugin.dll 	xpGwtDevPlugin.dll@0x8bef 	
3 	xpGwtDevPlugin.dll 	xpGwtDevPlugin.dll@0x8687 	
4 	xpGwtDevPlugin.dll 	xpGwtDevPlugin.dll@0x2246f 	
5 	xpGwtDevPlugin.dll 	xpGwtDevPlugin.dll@0x8cb6 	
6 	mozjs.dll 	JSObject::putProperty 	js/src/jsscope.cpp:899
7 	xpGwtDevPlugin.dll 	xpGwtDevPlugin.dll@0x226a7 	
8 	mozjs.dll 	js::Shape::set 	js/src/jsscopeinlines.h:282
9 	mozjs.dll 	JSObject::nativeSearch 	js/src/jsscope.h:692
10 	mozjs.dll 	js_SetPropertyHelper 	js/src/jsobj.cpp:5791
11 	xpGwtDevPlugin.dll 	xpGwtDevPlugin.dll@0x896f 	
12 	xpGwtDevPlugin.dll 	xpGwtDevPlugin.dll@0x8bef 	
13 	xpGwtDevPlugin.dll 	xpGwtDevPlugin.dll@0x2c1c7 	
14 	mozjs.dll 	js_SetProperty 	js/src/jsobj.cpp:5802
15 	mozjs.dll 	JSObject::setProperty 	js/src/jsobj.h:1232
16 	mozjs.dll 	js::Interpret 	js/src/jsinterp.cpp:4599
17 	xul.dll 	SearchTable 	obj-firefox/xpcom/build/pldhash.c:439
18 		@0x0 	

More reports at:
https://crash-stats.mozilla.com/report/list?range_value=4&range_unit=weeks&signature=xpGwtDevPlugin.dll%400x4ffd
I filed Bug 637284 for the Mac equivalent of this bug, so this is probably a dupe. There are a already a couple of crashes in early RC testing.

Comment 2

8 years ago
GWT worked fine up through Beta 11.  Beta 12 and RC both crash for me.
Crash Signature: [@ xpGwtDevPlugin.dll@0x4ffd ]
(Reporter)

Comment 3

7 years ago
There have been no crashes with their signature containing xpGwtDevPlugin.dll for the last four weeks.
I close it as WFM.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.