All users were logged out of Bugzilla on October 13th, 2018

the memcache lib needs to un-blacklist dead nodes faster

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
8 years ago
8 years ago

People

(Reporter: tarek, Assigned: tarek)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

8 years ago
Looks like the latest version of the python-memcached lib fails to restore if the Memcached server is restarted and the Python server stays loaded.

Need to investigate on this and fix it.
(Assignee)

Comment 1

8 years ago
It restores fine, but there's a 30 seconds lag before a dead node is retried again, which is too long for a simple memcached restarting.

I've asked Sean about this at https://bugs.launchpad.net/python-memcached/+bug/726654

And will patch it in the meantime so our apps can configure this value to 1 s.
Severity: major → normal
Status: NEW → ASSIGNED
(Assignee)

Updated

8 years ago
Summary: latest python-memcached seem not to restore of failures → the memcache lib needs to un-blacklist dead nodes faster
(Assignee)

Updated

8 years ago
Duplicate of this bug: 638392
(Assignee)

Comment 3

8 years ago
Well, We also need that patch: https://bugs.launchpad.net/python-memcached/+bug/728359
(Assignee)

Comment 4

8 years ago
I have asked Sean if he could look at those patch this week. If he does not have the time I will release a moz-specific RPM for our needs.
(Assignee)

Comment 5

8 years ago
We're going to move to pylibmc, so marking this as wontfix
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.