When visiting http://www.sprint-really-sucks.com, Seamonkey tries to load http://localhost

RESOLVED INVALID

Status

SeaMonkey
General
RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: Arthur K., Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0b13pre) Gecko/20110228 Firefox/4.0b13pre SeaMonkey/2.1b3pre
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b13pre) Gecko/20110228 Firefox/4.0b13pre SeaMonkey/2.1b3pre

I reported this way back in the early 2.0 days via the Report Broken Web Site tool but that's long since disappeared. I reported that when this page is visited, it tries to load http://localhost instead of http://www.sprint-really-sucks.com. Seems to work fine in Firefox 3.6.14 but I remember earlier versions of Firefox failing.

Reproducible: Always

Steps to Reproduce:
1. Copy and paste http://www.sprint-really-sucks.com into location bar
2. Try to navigate to http://www.sprint-really-sucks.com
Actual Results:  
Fails with "The connection was refused when attempting to contact localhost."

Expected Results:  
Should load and then proceed to http://www.sprint-really-sucks.com/Home.aspx

Also pasting http://www.sprint-really-sucks.com/Home.aspx into location bar fails to load the site.
The site redirects to localhost if the word "Monkey" is in the UA-String. If I change "SeaMonkey" to "Seamonkey" it loads correctly. Some loosy browser sniffing at work?
OS: Windows XP → All
Hardware: x86 → All

Comment 2

7 years ago
I think they have an overactive antispam system. I keep getting redirected to a webpage accusing me of being a spammer.
via http://web-sniffer.net and "your user agent" :

Status: HTTP/1.1 302 Found
Connection:	close	
Date:	Mon, 28 Feb 2011 16:45:03 GMT	
Server:	Microsoft-IIS/6.0	
MicrosoftOfficeWebServer:	5.0_Pub	
X-Powered-By:	ASP.NET	
Location:	http://localhost/	
Cache-Control:	private	
Content-Type:	text/html; charset=utf-8	
Content-Length:	134

changing the User Agent and you get another redirect :
Status: HTTP/1.1 302 Found
Connection:	close	
Date:	Mon, 28 Feb 2011 16:45:50 GMT	
Server:	Microsoft-IIS/6.0	
MicrosoftOfficeWebServer:	5.0_Pub	
X-Powered-By:	ASP.NET	
Location:	http://www.sprint-really-sucks.com/Home.aspx	
Cache-Control:	private	
Content-Type:	text/html; charset=utf-8	
Content-Length:	161

-> invalid (site problem)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.