Search Bookmarks/History window---Edit menu not functioning properly

VERIFIED INVALID

Status

P3
normal
VERIFIED INVALID
18 years ago
14 years ago

People

(Reporter: venur, Assigned: bugs)

Tracking

Trunk
Future

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; m18) Gecko/20001219
BuildID:    2000121214

In Search Bookmarks/History window , Edit menu is not working properly.
Select All is not selecting all items, copy also not copying. When an item is
selected manually by moving mouse on to that item, Edit options are (Expect
Select all) are not getting Enabled.. Is this Edit menu is really meant for
something in this window?

Reproducible: Always
Steps to Reproduce:
1.Bring up Mozilla Browser
2. Select Bookmarks-->Manage Bookmarks from the Navigator menu
3. Select Edit--> Find in Bookmarks in Manage Bookmarks window
4.Apply some criteria to search and obtain the results
5.select one or more items and observe Edit menu , try some options like Select
All, copy from Edit menu

Actual Results:  it should work in the same way as how every Edit menu behaves	

Expected Results:  Edit options are not getting enabled ot not working as they
are supposed to work

Comment 1

18 years ago
Yay!  This window has part of the classic Win95/98 Find dialog problem -- that 
is, it's Edit menu items only work on text in the find textfield (and not on 
selected tree items).
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows NT → All
Hardware: PC → All

Comment 2

18 years ago
No, the classic Win95/98 Find dialog problem is not that the menus don't work on
the search results (they work fine on the search results, but not on the search
text); the classic problem is that the dialog has menus at all
<http://developer.kde.org/documentation/standards/kde/style/basics/badInterface.html
>.

If the Find Bookmarks/History window is a dialog rather than a document window,
it can't have a menu bar. If it's document window rather than a dialog, it can't
have a Find button.

The search results should be shown in a separate window. That way, you can show
results of multiple searches at the same time.

Comment 3

18 years ago
mpt: Why is the location bar in Navigator any different from the find options 
at the top of the search window/dialog?  Showing each set of search results in 
a new window would make it harder to edit the searches, and generally make 
searching slower.

Btw, I also think the tree in Search Bookmarks should be multiselect and have 
context menus similar to those in Manage Bookmarks.

Comment 4

18 years ago
> mpt: Why is the location bar in Navigator any different from the find options
> at the top of the search window/dialog?

Because (a) searching is not the main role of a Navigator window, whereas it is 
the main role of the Find in Bookmarks window, and (b) it is very easy to open 
new Navigator windows to show multiple sets of results, whereas it is impossible 
to open new Find in Bookmarks dialogs to show multiple sets of results.

> Showing each set of search results in a new window would make it harder to edit
> the searches, and generally make searching slower.

You would need to press Ctrl+W to close the results window and return to the 
search field, or Alt+Tab to leave the results window open and return to the 
search field. I think that's a price worth paying in order to be able to show 
multiple sets of search results. And because focus would be returning to the 
search field from another window when you typed either of those combos, this 
would select the contents of the search field (bug 28583), eliminating the need 
to press Ctrl+A to replace the current search with a completely new one.

Comment 5

18 years ago
Looking into it.
Status: NEW → ASSIGNED
Priority: -- → P3
Target Milestone: --- → Future

Comment 6

18 years ago
This window no longer exists.

Should this bug be marked as invalid?

Comment 7

18 years ago
yes
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID

Comment 8

18 years ago
VERIFIED Invalid
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.