google search for "download firefox beta" returns en-GB locale and incorrect Firefox 3.5 product

RESOLVED DUPLICATE of bug 629787

Status

--
major
RESOLVED DUPLICATE of bug 629787
8 years ago
6 years ago

People

(Reporter: aphadke, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

search "download firefox beta" on google
first result includes:
Firefox 4 beta 8 which points to en-GB locale: http://www.mozilla.com/en-GB/firefox/beta/

Firefox 3.5 should actually be Firefox 3.6

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 629787
(Assignee)

Updated

7 years ago
Component: www.mozilla.org/firefox → www.mozilla.org
Product: Websites → Websites
(Assignee)

Updated

6 years ago
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.