Status

()

Firefox
Installer
RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: Gordon Hall, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b12) Gecko/20100101 Firefox/4.0b12
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b12) Gecko/20100101 Firefox/4.0b12

Firefox fails to check the Windows registry for the default install location and instead assumes c:\*.
Firefox should be checking the HKLM\Software\Microsoft\Windows\CurrentVersion key for the ProgramFilesDir or ProgramFilesDir(x86) string values to obtain the default program files path.

Reproducible: Always
We actually do default to the program files dir and check for one existing install (if there are two we default to the default install directory).

What are the specific symptoms you are experiencing and the steps to reproduce the symptoms?
(Reporter)

Comment 2

7 years ago
Steps to reproduce. Install windows 7, change HKLM\Software\Microsoft\Windows\CurrentVersion \ProgramFilesDir and/or ProgramFilesDir (x86) to point to somewhere else. IE a data drive rather than the system drive.  Made the change to windows as detailed above, rebooted the computer and installed Firefox.  Firefox defaulted to C:\Program Files (x86) which is not the default program files path on the system as specified by the registry key indicated above.
So, we use NSIS for the installer and it is what returns the value for program files directory. I'll take a look at what call it uses to determine the value.

Also see http://support.microsoft.com/kb/933700 - it is entirely possible that the MS provided API for determining the program files directory isn't using the registry value (I'm fairly certain of it since the API's for determining common directories often don't - likely due to the value being overrideable by group policy).
Did you also change the values at
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion
(Reporter)

Comment 5

7 years ago
No I hadn't, that node was overlooked.  Adjusted the values there, uninstalled Firefox and rebooted.  Reinstall now properly uses the correct default program files directory.  Thank you for your patience with this bug report.
Not a problem and thanks!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.