Closed Bug 637492 Opened 11 years ago Closed 8 years ago

Firefox crashes on startup [@ atidxx32.dll@0x2425e8 ]

Categories

(Core :: Graphics, defect)

x86
Windows 7
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: mailing_list, Unassigned)

Details

Attachments

(7 files)

User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b12) Gecko/20100101 Firefox/4.0b12
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0b12) Gecko/20100101 Firefox/4.0b12

Crash reports can be found at

http://crash-stats.mozilla.com/report/index/12bdcd02-da3c-485c-8dae-cbcf32110228
http://crash-stats.mozilla.com/report/index/bf817f6d-515c-4158-9e7b-deec82110228
http://crash-stats.mozilla.com/report/index/90a505bd-78fd-4daf-8a6a-9f1562110228

Graphics card is an AGP Radeon HD 2400 Pro.  The output of about:support is


  Allgemeine Informationen

        Name
        Firefox

        Version
        4.0b12

        User-Agent
        Mozilla/5.0 (Windows NT 6.1; rv:2.0b12) Gecko/20100101 Firefox/4.0b12

        Profilordner

          Beinhaltenden Ordner anzeigen

        Aktivierte Plugins

          about:plugins

        Build-Konfiguration

          about:buildconfig

  Erweiterungen

        Name

        Version

        Aktiviert

        ID

  Modifizierte Einstellungen

      Name

      Wert

        browser.places.smartBookmarksVersion
        2

        browser.startup.homepage_override.buildID
        20110222210221

        browser.startup.homepage_override.mstone
        rv:2.0b12

        extensions.lastAppVersion
        4.0b12

        font.default.x-user-def
        serif

        font.minimum-size.x-unicode
        14

        font.minimum-size.x-user-def
        14

        font.minimum-size.x-western
        14

        font.name.monospace.x-unicode
        Consolas

        font.name.monospace.x-user-def
        Consolas

        font.name.monospace.x-western
        Consolas

        font.name.sans-serif.x-unicode
        Corbel

        font.name.sans-serif.x-user-def
        Corbel

        font.name.sans-serif.x-western
        Corbel

        font.name.serif.x-unicode
        Palatino Linotype

        font.name.serif.x-user-def
        Palatino Linotype

        font.name.serif.x-western
        Palatino Linotype

        font.size.fixed.x-unicode
        14

        font.size.fixed.x-user-def
        14

        font.size.fixed.x-western
        14

        font.size.variable.x-unicode
        18

        font.size.variable.x-user-def
        18

        font.size.variable.x-western
        18

        gfx.font_rendering.directwrite.enabled
        true

        layers.acceleration.disabled
        true

        network.cookie.prefsMigrated
        true

        places.history.expiration.transient_current_max_pages
        21465

        privacy.sanitize.migrateFx3Prefs
        true

        security.warn_viewing_mixed
        false

  Grafik

        Karten-Beschreibung
        ATI Radeon HD 2400 Series

        Vendor-ID
        1002

        Geräte-ID
        94c4

        Karten-Ram
        256

        Karten-Treiber
        aticfx32 aticfx32 atiumdag atidxx32 atiumdva

        Treiber-Version
        8.821.0.0

        Treiber-Datum
        1-26-2011

        Direct2D aktiviert
        false

        DirectWrite aktiviert
        true (6.1.7601.17514, font cache n/a)

        WebGL-Renderer
        Google Inc. -- ANGLE -- OpenGL ES 2.0 (ANGLE 0.0.0.541)

        GPU-beschleunigte Fenster
        0/1

    

Reproducible: Always

Steps to Reproduce:
1. Start FF4b12 in normal mode.

Actual Results:  
Firefox start-up then crashes without further interaction.


Expected Results:  
No crash.

In safe mode FF4b12 doesn't crash.

A crash has been observed with FF4b11 and older graphics card drivers installed, too.
Your graphic card driver crashes
Component: General → Graphics
Product: Firefox → Core
QA Contact: general → thebes
Version: unspecified → Trunk
Reporter, you've set these two preferences:

        gfx.font_rendering.directwrite.enabled
        true

        layers.acceleration.disabled
        true

Can you reset them to their default values? (false)

I'll take a look at your crash reports once HBase comes back up...
(In reply to comment #2)
> Reporter, you've set these two preferences:
> 
>         gfx.font_rendering.directwrite.enabled
>         true
> 
>         layers.acceleration.disabled
>         true
> 
> Can you reset them to their default values? (false)

I had indeed set layers.accelaration.disabled to true during an IRC session at the #firefox channel yesterday.  I now started FF4b12 in safe mode, clicking "reset all user preferences to default" (translated from German) and hit the "restart" button.  After that FF4b12 started-up sucessfully.  But now with a font rendering issue that was the reason I went to the #firefox channel.  I'll attach a screenshot.  In addition to the font rendering issue, FF4b12 crashes on most sites I try to open, such as http://bugzilla.mozilla.org or http://www.heise.de.  The screenshot is from http://tug.org, which contains rather simple hand-written HTML only, AFAIK.  Are there any particular sites that I should test?

New crash reports:
http://crash-stats.mozilla.com/report/index/bp-1bfb96b3-52df-498b-ba6a-854d22110301
http://crash-stats.mozilla.com/report/index/bp-be3d3157-cc1e-4f8e-8138-9953e2110301
http://crash-stats.mozilla.com/report/index/bp-48cb927a-4751-4d21-aaf0-53df12110301
http://crash-stats.mozilla.com/report/index/bp-a92a2a51-cfea-41c5-9ad8-3e8fa2110301


This is the output of about:support in normal mode:

  Allgemeine Informationen

        Name
        Firefox

        Version
        4.0b12

        User-Agent
        Mozilla/5.0 (Windows NT 6.1; rv:2.0b12) Gecko/20100101 Firefox/4.0b12

        Profilordner

          Beinhaltenden Ordner anzeigen

        Aktivierte Plugins

          about:plugins

        Build-Konfiguration

          about:buildconfig

  Erweiterungen

        Name

        Version

        Aktiviert

        ID

        Feedback
        1.0.6
        true
        testpilot@labs.mozilla.com

  Modifizierte Einstellungen

      Name

      Wert

        browser.places.smartBookmarksVersion
        2

        browser.startup.homepage_override.buildID
        20110222210221

        browser.startup.homepage_override.mstone
        rv:2.0b12

        extensions.lastAppVersion
        4.0b12

        network.cookie.prefsMigrated
        true

        places.history.expiration.transient_current_max_pages
        21465

        privacy.sanitize.migrateFx3Prefs
        true

  Grafik

        Karten-Beschreibung
        ATI Radeon HD 2400 Series

        Vendor-ID
        1002

        Geräte-ID
        94c4

        Karten-Ram
        256

        Karten-Treiber
        aticfx32 aticfx32 atiumdag atidxx32 atiumdva

        Treiber-Version
        8.821.0.0

        Treiber-Datum
        1-26-2011

        Direct2D aktiviert
        true

        DirectWrite aktiviert
        true (6.1.7601.17514, font cache n/a)

        WebGL-Renderer
        Google Inc. -- ANGLE -- OpenGL ES 2.0 (ANGLE 0.0.0.541)

        GPU-beschleunigte Fenster
        1/1 Direct3D 10
Wow, that's some seriously broken rendering! It appears to affect the colored text, but black text renders OK. But it's not quite like that; note that the title "Welcome to the TeX Users Group web site" is OK, and the "courtesy of" (under the search box) is bad, even though it's black.

The "bad" text looks kind of like it's had the subpixel order messed up at some stage, whether during the initial rasterization of the glyphs or later during layer processing..... Bas, Roc, any thoughts?
This is very bad.

Stephan, you're running Windows 7 32-bit, right? And the Catalyst 11.2 package downloaded from AMD.com?

We need to get such a system built right quick. Either this is a very bad bug ATI has introduced, or it's a corrupted driver.
Keywords: qawanted
> Stephan, you're running Windows 7 32-bit, right?

Yes.  Professional, SP1.

> And the Catalyst 11.2 package downloaded from AMD.com?

Yes, 11.2.

> We need to get such a system built right quick.

It's an AGP card.  (AMD has different drivers for PCIe and AGP cards.)
Matt, we need iBeta to configure us a computer with the following specifications:

- Windows 7 32-bit SP1 professional
- AGP Radeon HD 2400 Pro
- Catalyst 11.2 drivers

We then need them to run through some smoketests on Beta 12.
Stephan,

To help us try to isolate this problem, our vendor (iBeta) has asked we get your msinfo and dxdiag files. I've found some links that should let you know how to get those - once you do, can you attach them to the bug?

dxdiag: http://www.matrixgames.com/forums/tm.asp?m=1866054
msinfo: http://www.laplink.com/support/kb/article.asp?ID=35
I'm on a different computer right now, but maybe the following information is already useful.  I'll attach the requested files later this evening.

board: ASRock, either K7VT4A Pro or K7VT4A+ (Socket A)
cpu: Athlon XP 2600+, OPN AXDA2600DKV3C
RAM: 1 GB
graphics card: GeCube GC-RX24PGA2-D3 (Radeon HD 2400 Pro, 256 MB, AGP)

This is exactly the rusty hardware that would benefit the most from hardware acceleration. :)
Attached file msinfo output
Attached file dxdiag output
Stephan, you're awesome. Thank you very much!

iBeta is going to receive their AGP card Thursday/Friday for further testing. If this is a widespread problem, we're going to have to start blocklisting something for sure.

Also - have you noticed any problems with other programs? Can you successfully run 3D games, for example? The sort of behaviour you're seeing is very bad and unexpected, which makes me wonder if/worry that you've got a virus or some other problem. It looks like you're the only person who's crashed in that location. :(
(Unless there are many people with AMD CPUs and Radeon HD 2400 Pros!)

Looking at your crash reports, though, there's nothing that jumps out at me as "this doesn't belong here."
(In reply to comment #13)

> Also - have you noticed any problems with other programs?

This machine serves as a cold backup, actually, and is not much tested with Windows 7.  I upgraded it to a WDDM 1.1 capable graphics card only recently.  But there's one thing that makes me start getting convinced it's an AMD driver problem.

I can occasionally observe a similar font rendering bug on window titles (only!) accross different applications when Aero is activated (attaching screenshot later).  I never observed that rendering bug with the old graphics card, Nvidia GeForce 6200, 256MB.  I haven't paid much attention to this, because font rendering within window canvases is always ok (and I can get around that bug by deactivating Aero).  But now this makes sense.  When Aero is activated, the only thing that's rendered through Windows' DirectWhatever are window titles.  And Firefox uses the same technique for rendering on the canvas when hardware acceleration in enabled.

Now for the bad news.  I have observed the same window title rendering bug on a similar machine, same board, but with a Sapphire Radeon HD 3450 (512 MB), driver 10.12, and Windows 7 Home Premium 32-bit, IIRC.  If this is really a driver issue, all WDDM1.1 capable ATI/AMD AGP cards could be affected.  But I can only get my hands on that machine over the weekend to test FF4b12.


> Can you successfully run 3D games, for example?

I have not much expertise in 3D games.  Can you suggest one?


> If this is a widespread problem, we're going to have to start blocklisting
> something for sure.

Would it be possible to disable hardware acceleration for font rendering only, but have other contents still be hardware accelerated?

And, since the drivers for WDDM 1.1 capable AGP cards still get monthly updates by AMD, how would I reenable hardware acceleration on a blocklisted card to test if the bug was fixed by AMD?
> board: ASRock, either K7VT4A Pro or K7VT4A+ (Socket A)

Note to the testers:

When trying to boot from an original Windows 7 DVD on this board, I get a "Code 5 Error - can not boot from disk".  To install Windows 7, I had to prepare a modified ISO with a different boot sector.  I have followed the recipe at <URL:http://www.unawave.de/windows-7-tipps/code-5-error.html>, using the boot sector provided by vLite.  Unfortunately, this page is in German and I haven't found a good English recipe.
(In reply to comment #14)

> But there's one thing that makes me start getting convinced it's an AMD driver
> problem.

I have done some cross-tests with IE9 RC and Google Chrome v9.0.597.107.

With IE symptoms are similar to FF4b12.  Wrong font rendering and frequent crashes.

Chrome, however, works flawless.  With default settings, I get a frame rate of about 4 fps at <URL:http://demos.hacks.mozilla.org/openweb/HWACCEL/>.  After activating "GPU Accelerated Canvas 2D" in about:flags, that raises to more than 30 fps.  Activating "CPU Accelerated Compositing" has no effect on frame rate.  I cannot observe any font rendering issues nor crashes, whatever the settings are.
An observation about the Aero window title bug (for which I don't know if it is actually related to the FF4RC crashes):

To work around that bug one doesn't need to deactivate Aero.  I haven't been able to reproduce the rendering bug with Aero enabled, but an opaque window color.  Switching back to transparent window color (selecting the predefined Windows-7-Basic design) the window title rendering bug re-appeared again after minimizing and maximizing a few windows.  So, that bug seems to be related to transparency.

Note, FF4RC crashes on start-up in normal mode if hardware acceleration is enabled, whatever the desktop design is.
(In reply to comment #18)
> Same symptoms with FF4RC: normal mode crashes.

Same symptoms with FF4RC2: normal mode crashes.

New crash reports:

<URL:http://crash-stats.mozilla.com/report/index/bp-ef0a1005-284d-4d08-a2e0-f811b2110320>
<URL:http://crash-stats.mozilla.com/report/index/bp-edb0c434-90a8-4f23-9438-839e82110320>
Stephan, can you try these things?
1.- Change the windows theme to classic
2.- Adjusting more quality - less speed in your graphics settings control panel
3.- right clicking the app shortcut  and disabling display scaling on high DPI settings under the Compatibility tab
4.- Enable ClearType  (Control Panel/Display/Appearance/Effects/Use the following method to smooth edges of screen fonts/ClearType)
5.- Trying gdipp http://code.google.com/p/gdipp/

Regards.
When I said "Enable ClearType" I wanted to say "Enable/Disable ClearType" - that is, testing in both ways

And, moreover:

6.- Do you have a big screen resolution? Can you change it temporarily to 1024x768 32bit-colour?
7.- Can you test enabling/disabling Direct2D and DirectWrite as explained here: http://www.askvg.com/how-to-enable-direct2d-directwrite-hardware-acceleration-in-mozilla-firefox/

Regards.
(In reply to comment #21)
> Stephan, can you try these things?
> 1.- Change the windows theme to classic
> 2.- Adjusting more quality - less speed in your graphics settings control panel
> 3.- right clicking the app shortcut  and disabling display scaling on high DPI
> settings under the Compatibility tab
> 4.- Enable ClearType  (Control Panel/Display/Appearance/Effects/Use the
> following method to smooth edges of screen fonts/ClearType)
> 5.- Trying gdipp http://code.google.com/p/gdipp/

(In reply to comment #22)
> When I said "Enable ClearType" I wanted to say "Enable/Disable ClearType" -
> that is, testing in both ways
> 
> And, moreover:
> 
> 6.- Do you have a big screen resolution? Can you change it temporarily to
> 1024x768 32bit-colour?

That's quite a number of combinations to try.  So far, I have tested with the following settings (now with the final FF4):

1. Select classic window theme.
2. Disable display scaling on high DPI settings in compatibility tab.
3. Change screen resolution to 1024x768.
4. Enable/disable ClearType.

Still, FF4 crashes.  Even though, it doesn't always crash on start-up, now.

Soft fact:  In particular, whenever starting-up FF4 just the first time after diabling ClearType, it seems to run a little more stable.  That is, it crashes only after some (text-oriented) sites have been visited (4 to 5 instead of just 1 or 2).

Hard fact:  Font rendering is always broken.  Also, navigating to graphics-oriented sites, such as <URL:http://demos.hacks.mozilla.org/openweb/HWACCEL/>, always crashes FF4.

BTW, your request to change the screen resolution reminded me, that I have a portrait resolution.  But I can confirm that FF4 crashes in portait mode as well as landscape mode in different resolutions (same for the window title rendering bug).


What I have not yet tried:

> 2.- Adjusting more quality - less speed in your graphics settings control panel

I remember such a setting in Windows XP, but I haven't found it neither in Windows 7 nor Catalyst Control Center.  Could you point me to that setting, please?


> 5.- Trying gdipp http://code.google.com/p/gdipp/

I will look into that later.

Best regards,
Stephan Hennig
(In reply to comment #22)

> 7.- Can you test enabling/disabling Direct2D and DirectWrite as explained here:
> http://www.askvg.com/how-to-enable-direct2d-directwrite-hardware-acceleration-in-mozilla-firefox/

With these settings:

1. Classic window theme.
2. Resolution 1024x768 (landscape).
3. ClearType disabled.

I have tried all six combinations of setting
    gfx.font_rendering.directwrite.enabled
        to
    true or false
and setting
    mozilla.widget.render-mode
        to
    -1, 0, or 6
by preparing a custom user.js file and placing it alongside prefs.js in the profile folder.

FF4 always crashes.

Any other settings I should try?
Any particular crash report you're interested in?

Best regards,
Stephan Hennig
Thank you very much Stephan.

According to your tests, it's quite plausible the problem resides in your motherboard. Your motherboard is not compatible with Windows 7, as you can see in these two webpages (K7VT4A PRO and K7VT4A+ models)

http://www.asrock.com/MB/download.asp?Model=K7VT4A%2b&o=All
http://www.asrock.com/MB/download.asp?Model=K7VT4A%20PRO&o=All

Due to there are not drivers for your motherboard, the OS knows *only partially* how to manage the input/output between the motherboard and the graphics card and (maybe equal o more important) between the graphics card and the mother board chipset. This causes you to have troubles rendering graphics specially when we talk about hw acceleration, which is graphics-card-model-independent, and then the OS doesn't know how to behave if we don't tell it how to do it.

There exists some ways to workaround these type of bugs. Did you have any OS installed before installing Windows 7? Which one? Were your graphics working correctly? If yes, you can use the drivers of your old OS as explained here (there are a lot of people who have got peripherals working in Win 7 with this trick):

http://es.kioskea.net/faq/3537-windows-7-forzar-la-instalacion-de-un-programa-o-controlador

You have to uninstall catalyst and all drivers first. Then, install windows xp drivers (graphics card and motherboard drivers) as explained in the above link

If you didn't have a OS working correctly in graphics, try the following method with the hacked .inf:

1) Uninstall Catalyst 

2) Download the Catalyst 9.11 32-bit driver Suite for Windows 7 from here - http://support.amd.com/us/gpudownload/windows/9-11/Pages/radeonaiw_vista32.aspx?&lang=English

3) Extract the driver folder by running the .exe you downloaded. 

4) Close installer after extraction. No longer necessary. Do not continue with install here.

5) Download my attachment (CL_91526.rar) and extract the .inf file from it. Save to desktop or anywhere you want.

6) Copy and paste the CL_91526.inf you just extracted directly overwriting the original at this location - C:\ATI\Support\9-11_vista32_win7_32_dd_ccc_wdm_enu\Driver\Packages\Drivers\Display\W7_INF

7) Go to device manager and right click on your video card. Update driver software, browse my computer, let me pick, have disk, browse.

8) Navigate to C:\ATI\Support\9-11_vista32_win7_32_dd_ccc_wdm_enu\Driver\Packages\Drivers\Display\W7_INF



9) Click (or double click) on the CL_91526.inf

10) Click ok, then click next and let it install. If it complains that it is not signed, click the part to let it install anyway.

11) Reboot if necessary. Pick an Aero theme by right clicking on desktop, Personalize. 

12) Run setup.exe in C:\ATI\Support\9-11_vista32_win7_32_dd_ccc_wdm_enu\Driver\
and let it complete to install the CCC, should you want the functionality. Custom mode is best used here instead of express mode, when it asks.

13) Install ATI Tray Tools (attsetup.rar in my attachments) if you wish to overclock. Ensure adequate cooling. Disclaimer - Should you choose to overclock, responsibility falls entirely on you.

14) Update your WEI score. Start menu | right click Computer | Properties | click Windows Experience Index


Yeah, a large method, but it may work after all. 

Regards.
Attached file CL_91526.rar
Attached file attsetup.part1.rar
Attached file attsetup.part2.rar
(In reply to comment #21)

> 5.- Trying gdipp http://code.google.com/p/gdipp/

With gdipp_x86_0.7.6.msi, FF4 still crashes.

The beta version gdipp_x86_0.9.1.msi itself crashes on Windows start-up with some hook related error.  (Sorry, I didn't note down the exact message.)

Both versions were installed as a Windows service.
(In reply to comment #25)

> According to your tests, it's quite plausible the problem resides in your
> motherboard. [...]
> 
> Due to there are not drivers for your motherboard, the OS knows *only
> partially* how to manage the input/output between the motherboard and the
> graphics card and (maybe equal o more important) between the graphics card and
> the mother board chipset. This causes you to have troubles rendering graphics
> specially when we talk about hw acceleration, which is
> graphics-card-model-independent, and then the OS doesn't know how to behave if
> we don't tell it how to do it.

OK.  Since this is only a secondary machine, I can well live without hardware acceleration.  But does this explain, why Chrome works well?  CCC shows that GPU load goes up in certain tests.  That is, Chrome is indeed using hardware acceleration.


> There exists some ways to workaround these type of bugs. Did you have any OS
> installed before installing Windows 7? Which one?

Windows XP Professional.


> Were your graphics working
> correctly? If yes, you can use the drivers of your old OS as explained here
> (there are a lot of people who have got peripherals working in Win 7 with this
> trick):
> 
> http://es.kioskea.net/faq/3537-windows-7-forzar-la-instalacion-de-un-programa-o-controlador

I have acquired the Radeon HD 2400 card only recently, but don't have an XP installation to test it anymore.  The old card was a DirectX 9.0c capable Nvidia Geforce 6200 that worked like a charme with Windows XP.  But to be honest, I don't know how to test 3D operation on Windows XP.


> If you didn't have a OS working correctly in graphics, try the following method
> with the hacked .inf:
> 
> 1) Uninstall Catalyst 
> 
> 2) Download the Catalyst 9.11 32-bit driver Suite for Windows 7 from here -
> http://support.amd.com/us/gpudownload/windows/9-11/Pages/radeonaiw_vista32.aspx?&lang=English

Thanks for the recipe!  I'll try to find the time to work through this list.  But as for the driver, wouldn't I need an old version of the AGP card driver?  The link looks like a PCIe card driver.  Unfortunately, I haven't found links to old AGP card drivers at amd.com.

Best regards,
Stephan Hennig
(In reply to comment #24)
> (In reply to comment #22)
> 
> > 7.- Can you test enabling/disabling Direct2D and DirectWrite as explained here:
> > http://www.askvg.com/how-to-enable-direct2d-directwrite-hardware-acceleration-in-mozilla-firefox/
> 
> With these settings:
> 
> 1. Classic window theme.
> 2. Resolution 1024x768 (landscape).
> 3. ClearType disabled.
> 
> I have tried all six combinations of setting
>     gfx.font_rendering.directwrite.enabled
>         to
>     true or false
> and setting
>     mozilla.widget.render-mode
>         to
>     -1, 0, or 6
> by preparing a custom user.js file and placing it alongside prefs.js in the
> profile folder.
> 
> FF4 always crashes.
> 
> Any other settings I should try?
> Any particular crash report you're interested in?
> 
> Best regards,
> Stephan Hennig

These config options are actually outdated sadly.

gfx.direct2d.disabled is the option you really want to set.

Also, Chrome makes use of the GPU at this point at a much more limited level than IE9 and FF4 do. This could explain the difference. It's good to know you're also seeing this with IE9 though, it's probably something Direct2D is doing.
(In reply to comment #31)

> >     gfx.font_rendering.directwrite.enabled
> >     mozilla.widget.render-mode
> 
> These config options are actually outdated sadly.
> 
> gfx.direct2d.disabled is the option you really want to set.

With gfx.direct2d.disabled set to true, I can confirm that:

  * font rendering is ok,

  * FF4 doesn't crash (checked several tests at IE9 test drive),

  * there seems to be no hardware acceleration any more,
    even though layers.acceleration.disabled is set to false.
> Stephan, you're running Windows 7 32-bit, right? And the Catalyst 11.2 package
> downloaded from AMD.com?
> 
> We need to get such a system built right quick. Either this is a very bad bug
> ATI has introduced, or it's a corrupted driver.

Today, AMD released the 11.3 driver edition and I can confirm that this driver solves all issues.  FF4 as well as IE9 now run on my configuration with hardware acceleration enabled without problems and the title rendering bug is gone, too.  After re-installing 11.2 again all issues re-appeared.  So, it was indeed a driver problem.  This bug can be closed.

Thanks to all who spent time on this!

Best regards,
Stephan Hennig
(In reply to comment #14)

> Now for the bad news.  I have observed the same window title rendering bug on a
> similar machine, same board, but with a Sapphire Radeon HD 3450 (512 MB),
> driver 10.12, and Windows 7 Home Premium 32-bit, IIRC.  If this is really a
> driver issue, all WDDM1.1 capable ATI/AMD AGP cards could be affected.  But I
> can only get my hands on that machine over the weekend to test FF4b12.

For the record:

I have been able to test FF4 on that other machine with an AGP Radeon HD 3450 now and can confirm that with AMD's 10.12 driver FF4 crashes there.  Again, installing the latest 11.3 driver solved all issues.  FF4 runs like a charme with hardware acceleration enabled and the window title rendering bug is gone.

At the same time, using a PCIe (!) Radeon HD 3650 on different boards (MSI K9AG Neo2-Digital and MSI K9A2 Neo-F), I have never observed any crashes or rendering bugs with 11.1 and 11.2 drivers.

To summarize:

On Windows 7 (32 bit), with the following AGP graphic cards

  * GeCube Radeon HD 2400 Pro, 256 MB, AGP (GC-RX24PGA2-D3)
  * Sapphire Radeon HD 3450, 512 MB, AGP (11160-01-20R)

and the board

  * ASRock K7VT4A Pro, Socket A

FF4 crashes when AMD drivers prior to version 11.3 are installed.  The problem seems to be related to AGP cards only.  But unfortunately, I have no other boards with an AGP port available to make more tests.

AMD's 11.3 driver edition solves the issue on the tested configurations and makes hardware acceleration work in FF4.

Best regards,
Stephan Hennig
Benoit, sounds like we need some blacklisting action here.
I'm not convinced we do, as this seems to be an isolated incident - iBeta, for example, built a computer very much like this and had no problems.
(In reply to comment #36)
> I'm not convinced we do, as this seems to be an isolated incident - iBeta, for
> example, built a computer very much like this and had no problems.

I have done some additional tests and can reproduce the crashes after a clean installation.

This time I had plugged the Radeon HD 2400 card into the other K7VT4A Pro board (for no reason).  This board has an older BIOS version 1.50, whereas the original board had BIOS version 1.80 (see msinfo output attached earlier).  Looking at the ASRock support site at <URL:http://www.asrock.com/mb/download.asp?Model=K7VT4A%20PRO&o=BIOS>, it looks like ASRock people had indeed messed with graphic card issues inbetween:

  1.70  6/16/2006  DOS  457.73KB  Patch Gecube RX1300 & RX1600Pro AGP Cards.

But this is in fact not relevant here, since I can reproduce the crashes with the old BIOS version 1.50 as well as with v1.80.  But I would be interested in the BIOS version iBeta is using.

What I have done (modulo several restarts):

1. Installed Windows 7 Professional, 32 bit, on a 25 GB partition on a 40 GB PATA drive.

Windows 7 has a basic driver for the Radeon HD 2400 Pro, dating April 2009.  With this driver I can already observe the title rendering bug, so that one is a very old bug.  (I still suspect the issues are related.)

After Windows 7 installation, audio drivers are still missing.

2. Installed drivers for a Belkin F5D7050 v4xxx WLAN stick.  (I doubt this is relevant to reproduce the bug.)

3. Run Windows Update and installed just the one optional update labeled "Microsoft driver update for VIA AC'97 Enhanced Audio Controller" (10/29/2008).  Nothing else.

After that, audio is working with clear sound and device manager looks fine.

4. Installed Firefox 4.

FF4 doesn't crash.  This is to be expected, since the graphic card driver shipped with Windows 7 doesn't support hardware acceleration.

5. Installed 11.2 AGP driver 11-2_agp-hotfix_vista_win7_32_dd_ccc.exe downloaded from amd.com before.

Unfortunately, I don't find a link to that driver any more.  Only links to 11.1 and 10.12 at the bottom of this link: <URL:http://forums.amd.com/game/messageview.cfm?catid=279&threadid=148211>.  But those should give the same results, according to tests done by me earlier.

Still FF4 doesn't crash.  Hmm.

6. Installed Windows 7 SP1 from file windows6.1-KB976932-X86.exe, placed on a USB flash stick.  The file had been downloaded on another computer at the Microsoft site before (ca. 540 MB).

Voilà, FF4 shows bad rendering and crashes!


Thinking about possible differences in hardware configurations iBeta and me are using:

* Is iBeta, by chance, using an SATA hard disk?  I have only PATA drives available to test.

* What mainboard BIOS version is iBeta using?

Best regards,
Stephan Hennig
> 5. Installed 11.2 AGP driver 11-2_agp-hotfix_vista_win7_32_dd_ccc.exe
> downloaded from amd.com before.
> 
> Unfortunately, I don't find a link to that driver any more.  Only links to 11.1
> and 10.12 at the bottom of this link:
> <URL:http://forums.amd.com/game/messageview.cfm?catid=279&threadid=148211>. 
> But those should give the same results, according to tests done by me earlier.
> 
> Still FF4 doesn't crash.  Hmm.
> 
> 6. Installed Windows 7 SP1 from file windows6.1-KB976932-X86.exe, [...]

There was actually a step 5.5 that I missed to add.  When FF4 didn't crash after installing the 11.2 driver, I first installed Adobe Flash Player v10.2.159.1, hoping the plug-in makes FF4 crash.  But it didn't.  After that, I went on installing Windows 7 SP1.

Best regards,
Stephan Hennig
You need to log in before you can comment on or make changes to this bug.