Closed Bug 637533 Opened 12 years ago Closed 12 years ago

Firefox 4.0b12 [@ hang | ntdll.dll@0xe514]

Categories

(Core Graveyard :: Plug-ins, defect)

x86
Windows XP
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: marcia, Unassigned)

Details

(Keywords: hang)

Attachments

(1 file)

http://tinyurl.com/4dclbk3 to the reports which are all Windows. #3 top overall crash for B12 with 2920 crashes so far.

Unfortunately at the moment I cannot paste the stack in the bug because the reports are not showing in Socorro.

Bug 637515 Comment 2 has some information relevant to this hang.
Frame 	Module 	Signature [Expand] 	Source
0 	ntdll.dll 	ntdll.dll@0xe514 	
1 	kernel32.dll 	WaitForSingleObject 	
2 	xul.dll 	google_breakpad::ExceptionHandler::WriteMinidumpOnHandlerThread 	toolkit/crashreporter/google-breakpad/src/client/windows/handler/exception_handler.cc:763
3 	xul.dll 	google_breakpad::ExceptionHandler::WriteMinidumpForException 	toolkit/crashreporter/google-breakpad/src/client/windows/handler/exception_handler.cc:778
4 	xul.dll 	google_breakpad::ExceptionHandler::WriteMinidump 	toolkit/crashreporter/google-breakpad/src/client/windows/handler/exception_handler.cc:820
5 	xul.dll 	CrashReporter::CreatePairedMinidumps 	toolkit/crashreporter/nsExceptionHandler.cpp:2089
6 	xul.dll 	mozilla::plugins::PluginModuleParent::ShouldContinueFromReplyTimeout 	dom/plugins/PluginModuleParent.cpp:256
7 	xul.dll 	mozilla::ipc::SyncChannel::ShouldContinueFromTimeout 	ipc/glue/SyncChannel.cpp:261
8 	xul.dll 	mozilla::ipc::RPCChannel::Call 	ipc/glue/RPCChannel.cpp:210
9 	xul.dll 	mozilla::plugins::PPluginInstanceParent::CallNPP_HandleEvent 	obj-firefox/ipc/ipdl/PPluginInstanceParent.cpp:408
10 	xul.dll 	mozilla::plugins::PluginInstanceParent::NPP_HandleEvent 	dom/plugins/PluginInstanceParent.cpp:1170
11 	xul.dll 	mozilla::plugins::PluginModuleParent::NPP_HandleEvent 	dom/plugins/PluginModuleParent.cpp:531
12 	xul.dll 	nsNPAPIPluginInstance::HandleEvent 	modules/plugin/base/src/nsNPAPIPluginInstance.cpp:579
13 	xul.dll 	nsPluginInstanceOwner::ProcessEvent 	layout/generic/nsObjectFrame.cpp:5450
14 	xul.dll 	nsPluginInstanceOwner::MouseMove 	layout/generic/nsObjectFrame.cpp:4697
15 	xul.dll 	nsEventListenerManager::HandleEventInternal 	content/events/src/nsEventListenerManager.cpp:1219
16 	xul.dll 	nsEventTargetChainItem::HandleEventTargetChain 	content/events/src/nsEventDispatcher.cpp:341
17 	xul.dll 	nsEventDispatcher::Dispatch 	content/events/src/nsEventDispatcher.cpp:628
18 	xul.dll 	PresShell::HandleEventInternal 	layout/base/nsPresShell.cpp:7066
19 	xul.dll 	PresShell::HandlePositionedEvent 	layout/base/nsPresShell.cpp:6900
20 	xul.dll 	PresShell::HandleEvent 	layout/base/nsPresShell.cpp:6731
21 	xul.dll 	nsViewManager::HandleEvent 	view/src/nsViewManager.cpp:1105
22 	xul.dll 	nsViewManager::DispatchEvent 	view/src/nsViewManager.cpp:1083
23 	xul.dll 	AttachedHandleEvent 	view/src/nsView.cpp:193
24 	xul.dll 	nsWindow::DispatchEvent 	widget/src/windows/nsWindow.cpp:3786
25 	xul.dll 	nsWindow::DispatchWindowEvent 	widget/src/windows/nsWindow.cpp:3809
26 	xul.dll 	nsWindow::DispatchMouseEvent 	widget/src/windows/nsWindow.cpp:4233
27 	xul.dll 	nsWindow::ProcessMessage 	widget/src/windows/nsWindow.cpp:5115
28 	xul.dll 	nsWindow::WindowProcInternal 	widget/src/windows/nsWindow.cpp:4613
29 	xul.dll 	nsIMM32Handler::ProcessMessage 	widget/src/windows/nsIMM32Handler.cpp:401
30 	xul.dll 	nsIMM32Handler::ProcessMessage 	widget/src/windows/nsIMM32Handler.cpp:401
31 	xul.dll 	xul.dll@0x359b4d
its tough to piece together flash version info and url info for these hangs since the two pieces of info live in opposite sides of the hang pair, but I'm working on a hack that might help with that.

top domains associated with this signature on 200 report sample of beta 12 on 20110227 looks something like this

  20 www.facebook.com
  18 apps.facebook.com
  16 www.youtube.com
   7 static.ak.fbcdn.net
   7 static.ak.facebook.com
   7 fb-0.frontier.zynga.com
   5 talkgadget.google.com
   5 src.actaads.com
   5 mycomet.mail.ru
   4 www.yabancidiziizle.com
   4 www.xtube.com
   4 www.nextplay.com
   4 vkontakte.ru
   4 qc-il.corp.emc.com
   4 internetorder.dominos.com.au
   3 www.ravenwoodfair.com
   3 www.orkut.com.br
   3 www.dizimag.com
   3 vgn-xpromo.vostu.com
   3 my.mail.ru
   3 fb-tc-0.farmville.com
...
...
...
here is what the flash version count breakdown looks like in the same sample.  looks like a more prevelent problem on 10.2, although not exclusive.

 169 10.2.152.26 [blank]
   3 10.2.161.23 [blank]
   1 10.2.152.21 [blank]
   1 10.2.151.49 [blank]
   1 10.1.102.64 

  47 10.1.102.64 [blank]
  12 10.1.85.3 [blank]
   8 10.1.82.76 [blank]
   1 [blank] 10.1.53.64


  31 [blank] [blank]
  4 [blank] 

   5 10.0.32.18 [blank]
   3 10.0.45.2 [blank]
   3 10.0.42.34 [blank]
   3 10.0.12.36 [blank]
   2 [blank] 10.1.82.76

   2 10.0.22.87 [blank]

   1 9.0.124.0
this signature doesn't really map well to any single individual signature on the plugin plugin side.  here is a listing of all the signatures in a sample of the pair reports.

 503 hang | ntdll.dll@0xe514
   5 hang | F_821451509__________________________________________________________
   5 hang | F_790366171________________________________________
   4 hang | F_875177159_________________________________________________________________
   3 hang | NPSWF32.dll@0x958a0
   3 hang | F_839780673_______________________________
   3 hang | F_596512829______________________________
   3 hang | F_1440603502__________________
   3 hang | F1361137843________________________________________________
   2 hang | F_632545334___________________
   2 hang | F_2090751469________________________________________________________________
   2 hang | F564047601_________________________________________________________________________
   1 hang | shell32.dll@0xbde7a
   1 hang | scale_line_8_c
   1 hang | mozilla::plugins::BrowserStreamChild::DeliverPendingData()
   1 hang | fastzero_I
   1 hang | fastcopy_I
   1 hang | Shockwave 3d Asset.x32@0x4f5a6
   1 hang | PixelBlit32Ato32_SSE
   1 hang | NPSWF32.dll@0x987ec
   1 hang | NPSWF32.dll@0x7cd05
   1 hang | NPSWF32.dll@0x7bff9
   1 hang | NPSWF32.dll@0x5b80b
   1 hang | NPSWF32.dll@0x3f7b3b
   1 hang | NPSWF32.dll@0x2331da
   1 hang | NPSWF32.dll@0x2310f6
   1 hang | NPSWF32.dll@0x231004
   1 hang | NPSWF32.dll@0x22ee3d
   1 hang | NPSWF32.dll@0x20402b
   1 hang | NPSWF32.dll@0x1e6afd
   1 hang | InterlockedCompareExchange
   1 hang | F_980482081__________________
   1 hang | F_573570822____________________________________________________
   1 hang | F_558249513____________________
   1 hang | F_477565519__________
   1 hang | F_2103495585_____________________________________________
   1 hang | F_2080806908_________________________
   1 hang | F_1776344327_____________________________________________
   1 hang | F_1644221920___________________________________
   1 hang | F_1603796674________________________________
   1 hang | F_1336544037__________
   1 hang | F_1308355634________________________________
   1 hang | F_1180069599_________________________________________________________________________________
   1 hang | F_1151984599_______________________
   1 hang | F_1090611750__________________
   1 hang | F948824071_________________________
   1 hang | F825216788_______________________
   1 hang | F818132354________________
   1 hang | F749175550____________________________________________________________________
   1 hang | F636812155__________________________________________________________________________________________________________________
   1 hang | F592615021_____________________________________________
   1 hang | F457974632____________________________
   1 hang | F374527877_____________________________________________
   1 hang | F351981279____________________________
   1 hang | F28161935________________
   1 hang | F272425357_________________________________
   1 hang | F226170198_______________________________________________________________________
   1 hang | F2109637189________________________________
   1 hang | F1956691869_______________________________________________________
   1 hang | F1949876734____________________________________________________
   1 hang | F1786948743_______________________________
   1 hang | F14507073______________________________________________________________________
   1 hang | F1282869874____________________________________
   1 hang | F1239283691__________________________________________________
   1 hang | F1188167450___________________________________
   1 hang | F1156974495_____________________
   1 hang | ConvertToRGB
   1 \N
(In reply to comment #0)
> http://tinyurl.com/4dclbk3 to the reports which are all Windows. #3 top overall
> crash for B12 with 2920 crashes so far.

Looks like all Windows XP SP3.

I think I am helping a user troubleshoot this hang at http://forums.mozillazine.org/viewtopic.php?f=23&t=2117453
bp-a20b5d33-5182-4f14-a067-ddbe52110228
(Sorry, no plugin report)

Firefox regularly hangs when uploading photos to Photobucket. I have tried myself with nightly and Flash 10.2.152.26 but am unable to reproduce:
Mozilla/5.0 (Windows NT 5.1; rv:2.0b13pre) Gecko/20110227 Firefox/4.0b13pre
built from http://hg.mozilla.org/mozilla-central/rev/5ff5318a9b04
This is just KiFastSystemCallRet, but we don't have Windows symbols for this particular version of ntdll.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → WORKSFORME
Windows symbol fetching will be fixed in bug 575817, which is waiting on bug 598908, which is slated for Socorro 1.7.7.
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.