Cannot find Plugin downloader plugin -> OK -> crash

VERIFIED WORKSFORME

Status

()

Core
Plug-ins
VERIFIED WORKSFORME
17 years ago
17 years ago

People

(Reporter: BenB, Assigned: av (gone))

Tracking

({crash})

Trunk
mozilla0.8
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Reproducable: Always
Reproduction:
1. Delete <instdir>/plugins/* (incl. libnullplugin.so)
2. Open a page which references a plugin
-> A dialog comes up, telling you that the automatic-plugin-downloading plugins
cannot be found. It has only an OK button and a checkbox "don't show again".]
3. Check "Don't show again".
4. Click OK.
-> Crash
5. Repeat step 2 and note that the dialog comes up again.

A user or distributor might not want the automatic downloader. Deleting it is
completely legal and makes sense.
(Reporter)

Updated

17 years ago
Keywords: crash

Comment 1

17 years ago
used 0108 linux trunk build. Went to java.sun.com, I do not see the crash, 
however the dialog does pop up again even after I select "Don't show again" 
chekbox the first time. reducing severity.
Severity: critical → normal
(Reporter)

Comment 2

17 years ago
Yup, I noticed later that it only happens at that special page I was visiting.
Sorry for forgetting to update the bug. Unfortuantely, I also forgot the URL of
the page causing the problem.

Updated

17 years ago
Keywords: crash
Summary: Cannot find Plugin downloader plugin -> OK -> crash → selecting 'Dont' show again' checkbox does not work.

Comment 3

17 years ago
removing crash keyword and resummarizing...
(Reporter)

Comment 4

17 years ago
No, it *is* a crasher, just that we lost the URL that happened to trigger it.
Please file a new bug about the "Don't show again" checkbox not working.
Keywords: crash
Summary: selecting 'Dont' show again' checkbox does not work. → Cannot find Plugin downloader plugin -> OK -> crash

Comment 5

17 years ago
ok will do, but u gotta get the url :)
(Reporter)

Comment 6

17 years ago
> u gotta get the url :)

I got to the page from an ad, so I have not much chance to find it again :-(.

Either a developer looks in the source sometime, or we close as WFM.

Comment 7

17 years ago
let me try to recreate this for a while...

Comment 8

17 years ago
This is a bad crash and probably happens a lot. Setting target milestone as this 
should be fixed.

Also, can you see if you get a stack trace on Linux? Thanks.
Target Milestone: --- → mozilla0.8
(Reporter)

Comment 9

17 years ago
> probably happens a lot

YOu have to delete the default plugin. While this is valid and will be done, I
wouldn't say, it happens a lot.

Sure, it should be fixed... :)

> Also, can you see if you get a stack trace on Linux?

Hardly, since I cannot reproduce it anymore.

Comment 10

17 years ago
ahh, I can't reproduce on either platforms. I do not crash at all (still 
trying..)
(Reporter)

Comment 11

17 years ago
For the unlikely case that it helps: I clicked on an ad for Audi, the German car
manufacturer, on a German page, so the problematic page was probably on
www.audi.de. (Yes, I checked my history already, but I don't have the URL there.)
(Assignee)

Comment 12

17 years ago
I was unlucky to reproduce the crash with yesterday trunk build on Linux. 
Marking WFM.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 13

17 years ago
Yes, I confirm. This is working nicely for me too.
(Reporter)

Comment 14

17 years ago
ok
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.