Closed Bug 637559 Opened 9 years ago Closed 9 years ago

Add logging to Android Bridge

Categories

(Core :: Widget: Android, defect)

x86
Android
defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: dougt, Assigned: dougt)

Details

Attachments

(2 files)

Add logging to Android Bridge.

Basically the interface from native code into java isn't noisy enough.  There have been perf hot spots (getting mime information) that went unnoticed, and crashes (dalvik leaks) caused by this bridge.

We should add basic logging so that we can see what is being called.
Attached patch patch v.1Splinter Review
Assignee: nobody → doug.turner
Attachment #515831 - Flags: review?(blassey.bugs)
Attachment #515831 - Flags: review?(blassey.bugs) → review+
pushed http://hg.mozilla.org/mozilla-central/rev/e244bdf7eff7
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
this one is unnecessarily noisy
Attachment #516050 - Flags: review?(doug.turner)
Comment on attachment 516050 [details] [diff] [review]
move HideProgressDialogOnce logging

thanks!
Attachment #516050 - Flags: review?(doug.turner)
Attachment #516050 - Flags: review+
Attachment #516050 - Flags: approval2.0+
You need to log in before you can comment on or make changes to this bug.