updating add-ons corrupts the files, causing reviews to be denied

RESOLVED FIXED

Status

RESOLVED FIXED
8 years ago
3 years ago

People

(Reporter: dietrich, Assigned: jorgev)

Tracking

Details

(Reporter)

Description

8 years ago
I uploaded new versions of 4-5 of my add-ons. So far, two of them "did not meet the criteria for being hosted in our gallery" because the file was not usable by the reviewer for some unknown reason.

1. Reviewers should specify what the problem is. For example, if the xpi is corrupt, say so. Is there a way to know if the upload failed for some reason? These files work fine locally.

2. If the reason something failed is because of an AMO problem, the text in the rejection email should be different. It's really frustrating to upload your add-on, and then get told that you "didn't meet the criteria" because of something that's not your fault. And then have to do it all again.
Assignee: nobody → jorge
(Reporter)

Comment 1

8 years ago
I don't know if it should be in this bug or a new one, but the process is getting even more hurty:

I tried to upload the file again but got denied because "version already exists". So I have to bump version and re-package for this.. arrrgh.

Then I saw there was a "resume process" link for the add-on the My Add-ons page, but that didn't let me re-upload the file, only re-request review.

And there's no way I can find to ask the reviewer "hey, what was the problem? did you try installing it and Firefox complained? What was the error - anything in the console?", etc.
(Assignee)

Comment 2

8 years ago
All review emails end with "If you have any questions or comments on this review, please reply to this email or join #addons on irc.mozilla.org". Can you verify that you have this in yours? Replying to the email will send the message to the editors mailing list, where these kind of issues are more easily dealt with.

If you want to continue discussing the file problem in this bug, it would be useful if you include the exact comments provided by the editor who reviewed your add-on.
(Reporter)

Comment 3

8 years ago
(In reply to comment #2)
> All review emails end with "If you have any questions or comments on this
> review, please reply to this email or join #addons on irc.mozilla.org". Can you
> verify that you have this in yours? Replying to the email will send the message
> to the editors mailing list, where these kind of issues are more easily dealt
> with.

Whoa, I had no idea you could have a dialogue with the reviewer via the emails!! I always click the link to go to AMO, and deal with stuff there.

I filed bug 638351 for making it really clear that the email is a conversation *with* the reviewer about the review.

> 
> If you want to continue discussing the file problem in this bug, it would be
> useful if you include the exact comments provided by the editor who reviewed
> your add-on.

Here they are. I got two more today. That's 4 of 5 now, IIRC.

<snip>
Your add-on, Flashtoggle 0.3, has been reviewed by an editor and did not meet the criteria for being hosted in our gallery.

Editor: Kris Maglione
Comments:
I'm sorry, but I can't download this file. Please upload it again. Thanks.
</snip>

At the least, we should allow re-upload, so devs don't have to bump versions and repackage for errors like this.

Is there anything in AMO that would log whether there was a problem uploading?
(In reply to comment #3)
> Is there anything in AMO that would log whether there was a problem uploading?

What's the URL to the file? Does it look fine when you download it?
(Reporter)

Comment 5

8 years ago
https://addons.mozilla.org/firefox/downloads/file/112497/flashtoggle-0.3-fx.xpi?src=devhub

Looks fine to me. I've uploaded a new version of FlashToggle since then, will see what the reviewer says this time.
(Assignee)

Comment 6

8 years ago
(In reply to comment #3)
> At the least, we should allow re-upload, so devs don't have to bump versions
> and repackage for errors like this.

You can delete the file inside the version and then upload a new one, or you can delete the version and then re-upload. It's not a requirement to bump the version.
(Assignee)

Comment 7

7 years ago
Marking this as fixed, since it's unclear what the problem was or how to reproduce, and the add-on is already up to version 0.4.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.