Sync does not preserve Bookmarks Toolbar order

RESOLVED DUPLICATE of bug 545647

Status

Cloud Services
Firefox Sync: Backend
RESOLVED DUPLICATE of bug 545647
7 years ago
7 years ago

People

(Reporter: gen, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
Sync used in Firefox 4 Beta12 and Minefield does not preserve the order of items on the Bookmarks Toolbar.

I recently used Sync with a new profile and imported everything from my Sync account.  The synced data was complete (afaict) but the items on the Bookmarks Toolbar were not in the same order as they were in other profiles used with the same Sync account.  I could not determine how they were placed- it was not alphabetical.
I've seen this problem with my account as well, but I didn't look for work-arounds. I wasn't aware this was still happening, but if it is it would be nice to have a way recover from this.
(Reporter)

Comment 2

7 years ago
I'm glad to hear I'm not the only one seeing this.  Do we have a way to know what the order is of items on the Bookmarks toolbar?  We'd need to save that and sync that alongside the data itself, yes?

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 545647
(In reply to comment #2)
> I'm glad to hear I'm not the only one seeing this.  Do we have a way to know
> what the order is of items on the Bookmarks toolbar?  We'd need to save that
> and sync that alongside the data itself, yes?

We do. Sync bookmark records include a "children" element, which is an ordered array of GUIDs.
You need to log in before you can comment on or make changes to this bug.