Closed Bug 637582 Opened 9 years ago Closed 9 years ago

blank or white page showing randomly when rendering or loading page

Categories

(Firefox for Android Graveyard :: General, defect, critical)

All
Android
defect
Not set
critical

Tracking

(fennec2.0+)

VERIFIED FIXED
Tracking Status
fennec 2.0+ ---

People

(Reporter: mevans, Assigned: blassey)

Details

Attachments

(3 files)

This has been a consistent, but intermittent issue reported on many android platforms. In the last fennec testday, many users experienced this. It is very hard to reproduce consistently. Seems to occur more frequently during page load and simultaneously either zooming, panning or canceling the page load. I have also seen it when a page reloads automatically as well.

One url that this behavior seemed to happen rather frequently is: 

http://www.myfoxny.com/dpp/news/charo-says-lady-gaga-is-madonna-with-diarrhea-20110225-lgf

Apologies to Lady GaGa fans :).
tracking-fennec: --- → ?
OS: Mac OS X → Android
Hardware: x86 → All
I haven't managed to reproduce this, but it showed up regularly in Market reviews for b5, and in our latest testday, and in feedback:

http://input.mozilla.com/en-US/beta/search?product=mobile&version=4.0b5&q=white
http://input.mozilla.com/en-US/beta/search?product=mobile&version=4.0b5&q=blank
Not sure if this is the same bug or not, but I often see blank white pages. Switching tabs back and forth makes the page paint properly.
tracking-fennec: ? → 2.0+
Whiteboard: [need-str]
I've seen this a couple times today. Each time there was a low memory message on the log.i'm thinking that what's happening is we're killing the content process but not reloading the visible tab afterwards
I see this pretty frequently on my Epic
I find that just closing one of the background tabs is enough to get content to paint again
Assignee: nobody → blassey.bugs
steps to reproduce here are to induce a low memory condition. It can probably also be reproduce artificially by sending a low memory notification with an addon.
Whiteboard: [need-str]
Attached patch patchSplinter Review
Attachment #517166 - Flags: review?(mbrubeck)
Comment on attachment 517166 [details] [diff] [review]
patch

Please add a one-line comment explaining what this fixes.  r=mbrubeck with that change.

I'm curious why this was necessary, since we try not to zombify the selected tab...
Attachment #517166 - Flags: review?(mbrubeck) → review+
Whiteboard: [has patch][has review][can land with nit fix]
pushed https://hg.mozilla.org/mobile-browser/rev/08533b697c63
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Whiteboard: [has patch][has review][can land with nit fix]
Attached image offscreen text
Mozilla/5.0 (Android; Linux armv71; rv2.0b13pre) Gecko/20110308 Firefox/4.0b13pre Fennec/4.0b6pre
Device: Droid 2 
OS: Android 2.2

I was still able to get an error, I had to zoom, pan, reload all over the place.
Prior to the error, I noticed that there were some text that were off-screen.
Attached image error screenshot
error screen shot; it took a lot more effort to get the error with the patch
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
If you're getting an error dialog, that's just a regular content process crash (probably OOM).  This bug was about content process crashes that resulted in a white screen with no dialog.
Status: REOPENED → RESOLVED
Closed: 9 years ago9 years ago
Resolution: --- → FIXED
I'm not happy with the bandaid patch that landed here. We should be trying to figure out why the tab needed to be selected twice, and fix that problem.
Matt Evans, can you check if your issue still happens on the latest nightly?   A proper fix should probably be filed in a different bug.
I've tried on current fennec and will try on RC1 build2 tonite. But so far things look much better. I have seen the blank page once, but it was a launch from tweetdeck. No blank page during browsing tho.
Going to mark verified based on comment 15.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.