Flash crash with celebratetechnology.com.sg page, then tab unusable

RESOLVED WORKSFORME

Status

()

Core
Plug-ins
RESOLVED WORKSFORME
7 years ago
5 years ago

People

(Reporter: gkw, Unassigned)

Tracking

Trunk
x86
Windows 7
Points:
---

Firefox Tracking Flags

(blocking2.0 -)

Details

(URL)

(Reporter)

Description

7 years ago
Accessing http://www.celebratetechnology.com.sg/timeline_gc generates a slow script error with Flash then Flash crashes. On Flash 10.2.152.26 with Firefox 4 Beta 12.

On the Firefox side, I am unable to carry on selecting the URL bar after Flash crashes. I have to close the tab. Sometimes, Firefox even freezes up and/or crashes, but these are rare.

Filing in Core -> Plugins because Firefox might have some involvement in this.

Nominating for .x+.

Comment 2

7 years ago
Confirmed with Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b13pre) Gecko/20110228 Firefox/4.0b13pre ID:20110228030400 and Flash 10,2,152,26

bp-3b4bf72e-4b4b-4633-95ac-20ae52110301
bp-a73d04e8-5643-475a-a822-f43642110301

However, what was weird is that after the hang, even if I switched to other tabs/opened a new tab, the awesome bar stopped working. ie: clicking in it did not show a flashing cursor, i could still type, but hitting enter to navigate to the URL (about:crashes in this instance) did not work. Closing the tab where flash crashed had no effect, Firefox had to be restarted in order to fix.

Comment 3

7 years ago
Did you see the Flash slow-script dialog, or the Firefox one?
blocking2.0: ? → -
Whiteboard: DUPEME

Comment 4

7 years ago
Hrm, this should have been bug 570249, but we fixed that...

Comment 5

7 years ago
For me, "script running slowly, do you want to stop it", to which pressed no, then page/flash object carried on not responding for a bit, then "oops this plugin has crashed" placeholder UI shown.

Comment 6

7 years ago
(In reply to comment #3)
> Did you see the Flash slow-script dialog, or the Firefox one?

I received the flash dialog. I didn't have any focus issues after we kill the child though.
(Reporter)

Comment 7

7 years ago
(In reply to comment #6)
> I received the flash dialog. I didn't have any focus issues after we kill the
> child though.

The awesome bar does not seem to work properly in that tab after the plugin crashes. That seems to be the issue, not the focus issue.

Is the awesomebar supposed to stop working properly when a plugin crashes?

Comment 8

7 years ago
(In reply to comment #7)
> (In reply to comment #6)
> > I received the flash dialog. I didn't have any focus issues after we kill the
> > child though.
> 
> The awesome bar does not seem to work properly in that tab after the plugin
> crashes. That seems to be the issue, not the focus issue.
> 
> Is the awesomebar supposed to stop working properly when a plugin crashes?

No it's not.

On a second attempt I experienced the awesome bar cursor problem. The experience is identical to bug 537325.
(Reporter)

Comment 9

6 years ago
(In reply to Gary Kwong [:gkw, :nth10sd] from comment #7)
> (In reply to comment #6)
> > I received the flash dialog. I didn't have any focus issues after we kill the
> > child though.
> 
> The awesome bar does not seem to work properly in that tab after the plugin
> crashes. That seems to be the issue, not the focus issue.
> 
> Is the awesomebar supposed to stop working properly when a plugin crashes?

The awesome bar works properly now. Tested with Build identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:12.0a2) Gecko/20120217 Firefox/12.0a2

and Flash version 11.1.102.62.

I get the slow script Flash dialog, as expected.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME

Updated

5 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.